Ask Your Question
0

Red Hat RDO: packstack --allinone: no 'mongodb-server' package

asked 2014-08-10 04:20:53 -0500

JohnSmith gravatar image

updated 2014-08-10 04:22:34 -0500

Hi,

Im trying out 'packstack --allinone' on Centos 6.5, but am getting this error:

Error: Execution of '/usr/bin/yum -d 0 -e 0 -y list mongodb-server' returned 1: Error: No matching Packages to list

When going through the documentation on 'mongodb.org', it looks like you have to enable an extra repository, and then the package is named 'mongodb-org-server' and not 'mongodb-server'. (1.)

Is this a bug ?

Thank,

John Smith.

  1. http://docs.mongodb.org/manual/tutorial/install-mongodb-on-red-hat-centos-or-fedora-linux (http://docs.mongodb.org/manual/tutori...)
edit retag flag offensive close merge delete

Comments

Try to install mongodb-server before running packstack
# yum -y install mongodb-server

dbaxps gravatar imagedbaxps ( 2014-08-10 08:10:22 -0500 )edit

Thanks. But that doesnt work either, and for the same reason: yum cant find the 'mongodb-server' package. Doesnt matter whether i try to 'yum list' or 'yum install' it.

JohnSmith gravatar imageJohnSmith ( 2014-08-10 08:18:41 -0500 )edit

$ yum search mongodb*

dbaxps gravatar imagedbaxps ( 2014-08-10 08:21:51 -0500 )edit

Maybe somebody messed up the RDO repository ?

JohnSmith gravatar imageJohnSmith ( 2014-08-10 08:33:54 -0500 )edit
2

The package just does not seem to be there. I have tried several methods to retrieve the package and that is the conclusion I keep coming back to.

Bill gravatar imageBill ( 2014-08-10 09:25:10 -0500 )edit

2 answers

Sort by ยป oldest newest most voted
0

answered 2014-08-12 06:14:06 -0500

sagara gravatar image

Thanks Manoj to write why '/usr/bin/yum -d 0 -e 0 -y list mongodb-server' fails.

This is temporary workaround details. (Ceilometer enabled)


You need to download below packages from out of sync EPEL repo manually, like http://ftp.is.co.za/mirror/fedora.redhat.com/epel/6/x86_64/ (http://ftp.is.co.za/mirror/fedora.red...)

  • mongodb-2.4.6-1.el6.x86_64.rpm
  • mongodb-server-2.4.6-1.el6.x86_64.rpm

And you need to download below packages from anywhere EPEL repo manually, like http://dl.fedoraproject.org/pub/epel/6/x86_64/ (http://dl.fedoraproject.org/pub/epel/...)

  • gperftools-libs-2.0-11.el6.3.x86_64.rpm
  • v8-3.14.5.10-9.el6.x86_64.rpm
  • libunwind-1.1-2.el6.x86_64.rpm

Install dependency packages, and run packstack.

[root@localhost ~]# yum install -y boost-thread boost-filesystem boost-program-options boost-system boost-iostreams libpcap snappy libicu
[root@localhost ~]# rpm -ivh mongodb-2.4.6-1.el6.x86_64.rpm mongodb-server-2.4.6-1.el6.x86_64.rpm gperftools-libs-2.0-11.el6.3.x86_64.rpm v8-3.14.5.10-9.el6.x86_64.rpm libunwind-1.1-2.el6.x86_64.rpm
[root@localhost ~]# packstack --allinone

(After packstack, EPEL repo setting (/etc/yum.repos.d/epel.repo) will be added.)

edit flag offensive delete link more
0

answered 2014-08-10 14:48:52 -0500

Manoj gravatar image

This appears to be due to broken EPEL 6 repo. this worked on Thursday/Friday when I last tried and refuses to work today. mongodb-server was provided by EPEL and I no longer see the rpm in EPEL 6 repo.

I opened a bug in Redhat's bugzilla: https://bugzilla.redhat.com/show_bug.cgi?id=1128488 (https://bugzilla.redhat.com/show_bug....)

And I found a EPEL mirror which is not(luckily) in sync with EPEL's primary mirror.

edit /etc/yum.repos.d/epel.repo and add "http://ftp.is.co.za/mirror/fedora.redhat.com/epel/6/x86_64/" as baseurl for epel repo.

not sure how long this mirror will stay out of sync, but try your luck.

Thanks Manoj

edit flag offensive delete link more

Comments

According to that bugzilla bug report, it was deliberately removed from the EPEL 6 repository due to unfixed/unfixable security issues.

JohnSmith gravatar imageJohnSmith ( 2014-08-11 05:29:47 -0500 )edit

Lets see what happens now: https://bugzilla.redhat.com/show_bug.cgi?id=1128777 (https://bugzilla.redhat.com/show_bug....) I opened another bug with Redhat as this would need a fix in Packstack and packstack should install alternate mongodb packages from http://mongodb.org .

Manoj gravatar imageManoj ( 2014-08-11 09:26:51 -0500 )edit

Looks like that first bug report got closed with : 'CANTFIX' https://bugzilla.redhat.com/show_bug.cgi?id=1128488 (https://bugzilla.redhat.com/show_bug....)

JohnSmith gravatar imageJohnSmith ( 2014-08-11 09:34:22 -0500 )edit

As a temporary workaround until this get fixed properly, you can work around the issue by not installing ceilometer. Run 'packstack --os-ceilometer-install=n', or if you are using an answers file, you can set CONFIG_CEILOMETER_INSTALL=n.

JohnSmith gravatar imageJohnSmith ( 2014-08-11 10:02:57 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

3 followers

Stats

Asked: 2014-08-10 04:20:53 -0500

Seen: 1,420 times

Last updated: Aug 10 '14