Ask Your Question
0

packstack installer runs forever on provision_demo.pp

asked 2014-08-09 06:24:51 -0600

D43m0n gravatar image

I'was unable to get an instance actually running with the RDO quick start guide ( http://openstack.redhat.com/Quickstart ), for which I've asked a question. So I decided to start over from scratch.

I've tried several installation methods with the packstack installer. The very first which installed fine was with the packstack --allinone command. Something however was not right, because a Fedora 19 instance ( http://openstack.redhat.com/Running_an_instance (http://openstack.redhat.com/Running_a...) ) kept stuck at spawning.

Next I tried to generate an answer file first, and then use that to install openstack with packstack using:

packstack --gen-answer-file=my-answer-file.txt
packstack --answer-file=my-answer-file.txt

That installation got stuck at:

Applying 10.0.129.104_horizon.pp
10.0.129.104_neutron_fwaas.pp:                     [ DONE ]
10.0.129.104_osclient.pp:                          [ DONE ]
10.0.129.104_horizon.pp:                           [ DONE ]
Applying 10.0.129.104_ring_swift.pp
10.0.129.104_ring_swift.pp:                        [ DONE ]
Applying 10.0.129.104_swift.pp
Applying 10.0.29.104_provision_demo.pp
10.0.129.104_swift.pp:                             [ DONE ]
Testing if puppet apply is finished: 10.0.129.104_provision_demo.pp  [ / ] 

which is not what I expected from my first experience. So I thought, "what the heck, I'll give it another shot". So I wiped the server, did a clean installation and tried the previous command again packstack --allinone.

That is now sitting at the exact same point in installation for more than 24 hours. Packstacks last few lines of the installation log says:

2014-08-08 08:47:42::INFO::shell::81::root:: [localhost] Executing script:
rpm -q --requires openstack-puppet-modules | egrep -v "^(rpmlib|\/|perl)"
2014-08-08 08:47:42::INFO::shell::81::root:: [10.0.129.104] Executing script:
rpm -q --whatprovides puppet || yum install -y puppet
rpm -q --whatprovides openssh-clients || yum install -y openssh-clients
rpm -q --whatprovides tar || yum install -y tar
rpm -q --whatprovides nc || yum install -y nc
rpm -q --whatprovides rubygem-json || yum install -y rubygem-json
2014-08-08 08:47:58::INFO::shell::81::root:: [localhost] Executing script:
cd /usr/lib/python2.6/site-packages/packstack/puppet
cd /var/tmp/packstack/20140808-084659-JU9GAG/manifests
tar --dereference -cpzf - ../manifests | ssh -o StrictHostKeyChecking=no -o UserKnownHostsFile=/dev/null root@10.0.129.104 tar -C /var/tmp/packstack/478af4613d1a4ac2a74c98e127988e36 -xpzf -
cd /usr/share/openstack-puppet/modules
tar --dereference -cpzf - apache ceilometer certmonger cinder concat firewall glance heat horizon inifile keystone memcached mongodb mysql neutron nova nssdb openstack packstack qpid rabbitmq rsync ssh stdlib swift sysctl tempest vcsrepo vlan vswitch xinetd | ssh -o StrictHostKeyChecking=no -o UserKnownHostsFile=/dev/null root@10.0.129.104 tar -C /var/tmp/packstack/478af4613d1a4ac2a74c98e127988e36/modules -xpzf -

I wonder how it is possible that the first attempt of installing openstack got me to the end, but that a few consecutive attempts now won't complete? I've wiped the entire server to make sure nothing unfinished gets in the way.

I'm running on a 5 year old HP DL380 G5 with 8 GB RAM and a quad core Intel(R) Xeon(R) CPU E5440 @ 2.83GHz on a 72GB SmartArray P400 RAID-controller ... (more)

edit retag flag offensive close merge delete

4 answers

Sort by ยป oldest newest most voted
1

answered 2014-09-17 00:24:00 -0600

Hello, it may due to the space available for /var. I ran into a similar issue with a 2GB logical volume. I extended it to 6GB (less might be possible) and installation resumed.

Hope it helps, Greg

edit flag offensive delete link more
0

answered 2017-04-24 13:35:22 -0600

jklu gravatar image

Check if you have enough RAM using 'top' It turns out that 'packstack --allinone' will install as many workers as cores available. Solution for me was:

CONFIG_SERVICE_WORKERS=1

in the answerfile

edit flag offensive delete link more
0

answered 2017-04-24 10:19:05 -0600

dbaxps gravatar image

Just CONFIG_PROVISION_DEMO=n in generated answer-file.

edit flag offensive delete link more
0

answered 2017-04-22 07:13:27 -0600

Madhukar gravatar image

updated 2017-04-22 07:14:33 -0600

Hi,

how was the error resolved ? I am seeing the same problem. Please note that disk space isnt a constraint on my server.

edit flag offensive delete link more

Comments

I'm having the same problem as well. I've been searching and so far I've heard that it could be that the server needs more resources, but I gave my VM 6GB RAM and 25GB of storage, so idk how true that is

Luckys gravatar imageLuckys ( 2017-04-27 05:06:36 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

3 followers

Stats

Asked: 2014-08-09 06:24:51 -0600

Seen: 3,678 times

Last updated: Apr 24 '17