Ask Your Question

Devstack install - Gateway is not valid on subnet

asked 2014-08-08 02:51:48 -0500

gepetto gravatar image

updated 2014-08-08 15:27:26 -0500

smaffulli gravatar image

I am working my way through the installation of Devstack on Centos 6.5 and have a network configuration issue. This is a test system and I can have my way with it. My physical network is as follows: - router / gateway to outside world, <br> - 99 - not used, <br> - 200 - dhcp address pool provided by router / gateway, <br> - dhcp address provided to Centos 6.5 system, <br> - 223 - not used, <br> - 255 - Selected for FLOATING_RANGE

I have made the following changes to local.conf:

HOST_IP=       <--  this is the Centos 6.5 machine eth0<br>
FLOATING_RANGE=  <-- unused ip addresses on the existing network<br>
FIXED_RANGE=  <-- this is what I am hoping will be my virtual network<br>

I ssh into the machine from a tablet execute ./ & as the user where I performed the git, etc. Amazing things happen for a while... and then the process terminates with the following error:

[ERROR] /home/gepetto/devstack/functions-common:433 Failure creating SUBNET_ID for 265da70366a142da9357d97af5ab254c<br>

Above the error in the log I see the following statement:

neutron subnet-create --tenant-id 265da70366a142da9357d97af5ab254c --ip_version 4 --gateway --name private-subnet 2cd403ce-70b5-406d-8bf8-32b0f44a1dd0<br>

I'm not sure how to resolve my configuration issues at this point. Is it possible that I have a conflict between the existing physical router / gateway (also and the virtual one being created? A possible dhcp conflict between the hardware and q-dhcp? I'm not sure what to try next. Do I understand the network parameters? Too much info, not enough info, what did I forget? Below are the last 13 lines of

This was a fresh install of Centos 6.5, updates applied, and Devstack installed. As I make my way through my errors, I execute, reboot, make changes to local.conf, and re-execute

2014-08-08 06:50:37.120 | ++ neutron subnet-create --tenant-id 265da70366a142da9357d97af5ab254c --ip_version 4 --gateway --name private-subnet 2cd403ce-70b5-406d-8bf8-32b0f44a1dd0<br>
2014-08-08 06:50:37.120 | ++ read data<br>
2014-08-08 06:50:37.123 | ++ grep ' id '<br>
2014-08-08 06:50:38.956 | Invalid input for operation: Gateway is not valid on subnet. (HTTP 400) (Request-ID: req-d00c4f0f-2518-47fe-8d96-6ec2f45f4370)<br>
2014-08-08 06:50:39.030 | + SUBNET_ID=<br>
2014-08-08 06:50:39.030 | + die_if_not_set 433 SUBNET_ID 'Failure creating SUBNET_ID for 265da70366a142da9357d97af5ab254c'<br>
2014-08-08 06:50:39.030 | + local exitcode=0<br>
2014-08-08 06:50:39.037 | [Call Trace]<br>
2014-08-08 06:50:39.037 | ./<br>
2014-08-08 06:50:39.037 | /home/gepetto/devstack/lib/neutron:433:die_if_not_set<br>
2014-08-08 06:50:39.037 | /home/gepetto/devstack/functions-common:251:die<br>
2014-08-08 06:50:39.044 | [ERROR] /home/gepetto ...
edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted

answered 2014-08-15 01:05:31 -0500

gepetto gravatar image

After much frustration I was able to get past the error. Attempts were made with multiple VBox guests, both Centos and Ubuntu - Actually thought I had it on the Ubuntu 12.04 VM since it appeared to fail on a timeout waiting for c-api to start. ps -ef revealed that cinder had indeed started. Thought that failure was due to the system being a VM and me probably doing something in the host system that caused a delay in the VM. I swapped out the hard drive and did a fresh install of UB 12.04 to give it both processors and all of the memory. I kept thinking about one page I saw that said 'just follow the three steps...' Anyway, I copied in the local.conf used in the UB12.04 devstack install, modified the local.conf to reflect the current IP address, ssh'd in from a tablet and gave ./ a go. No joy again, but it failed with the error above and not the timeout. Then I started commenting out lines in the local.conf. First to go were PUBLIC_INTERFACE and FLAT_INTERFACE (let the script find them...). Still no joy.

Next to go was a section I found that said add this to enable Neutron on a single node:

# enable - In order to enable Neutron a single node setup, you'll need the
#          following settings in your `local.conf`:

    #disable_service n-net
    #enable_service q-svc
    #enable_service q-agt
    #enable_service q-dhcp
    #enable_service q-l3
    #enable_service q-meta
    #enable_service q-metering
    # Optional, to enable tempest configuration as part of DevStack
    #enable_service tempest

FINALLY!! The build / install completed! I can log in and access the dashboard via the browser on the local machine. Looking around everything looks reasonable, but then again I really don't know what I am doing.

Here are the changes I made / kept in local.conf:


disable_service rabbit
enable_service qpid


Also copied to devstack directory without changes - had seen the last two lines related to port 22 / ssh and felt it may be needed.

At this point I can start to play with it and hopefully make some better mistakes. I may try to get the Centos and Ubuntu Vbox VMs working.

edit flag offensive delete link more

answered 2015-08-18 03:28:24 -0500

Your Network Gateway is a hard coded information given in lib/neutron-legacy: Thats why when you do not provide the information in the local.conf, it uses this value. The same reason why it worked the second time when you changed the information to

I am also trying to experiment and find out if there is a way to enable neutron with the appropriate gateway information and using the settings which you removed

#disable_service n-net
#enable_service q-svc
#enable_service q-agt
#enable_service q-dhcp
#enable_service q-l3
#enable_service q-meta
#enable_service q-metering
edit flag offensive delete link more


After some analysis, I was able to run neutron but by using default information( i.e. I removed the Floating and Fixed Range information.) I will still be experimenting and posting my results here

reedip-banerjee gravatar imagereedip-banerjee ( 2015-08-18 19:33:39 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

[hide preview]

Get to know Ask OpenStack

Resources for moderators

Question Tools



Asked: 2014-08-08 02:51:48 -0500

Seen: 2,177 times

Last updated: Aug 15 '14