Ask Your Question
2

Glance Image create : HTTPInternalServerError (HTTP 500) [closed]

asked 2014-08-07 23:40:24 -0500

humblearner gravatar image

I am trying to install Icehouse from : http://docs.openstack.org/icehouse/install-guide/install/apt/content/glance-verify.html.

I tried other posts in the forum for this problem but no luck:

System info:

root@hb067148:/tmp/images# uname -a
Linux hb067148 3.5.0-54-generic #81~precise1-Ubuntu SMP Tue Jul 15 04:02:22 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux

Issue:

root@hb067148:/tmp/images# glance image-create --name "cirros-0.3.2-x86_64" --disk-format qcow2   --container-format bare --is-public True --progress < cirros-0.3.2-x86_64-disk.img
[=============================>] 100%
HTTPInternalServerError (HTTP 500)

Logs and Conf:

http://paste.openstack.org/show/91848/ (glance-registry.conf)

http://paste.openstack.org/show/91852/ (glance-api.conf)

http://paste.openstack.org/show/91854/ (/var/log/glance/registry.log)

http://paste.openstack.org/show/91856/ (/var/log/glance/api.log)

Other info:

I also tried the following command from one of the forums question:

root@hb067148:/tmp/images# echo "INSERT INTO images (created_at, updated_at, deleted_at, deleted, id, name,   disk_format, container_format, size, status, is_public, checksum, min_disk, min_ram, owner, protected)         VALUES ('2013-01-18 17:00:00', '2013-01-18 17:00:00', NULL, 0, '53c06e6d-ced7-4ee0-9a92-acfc2d8219c7', 'tty-linux-kernel', 'aki', 'aki', 4404752, 'queued', 0, NULL, 0, 0, 'f9a70976a8064aceb3523191e03d8c1c', 0);"       | mysql -uglance -pfcplugin glance

root@hb067148:/tmp/images# mysql -uglance -pfcplugin glance
Reading table information for completion of table and column names
You can turn off this feature to get a quicker startup with -A

Welcome to the MySQL monitor.  Commands end with ; or \g.
!                                   !                                   !                                           
mysql> use glance;
Database changed

mysql> SHOW TABLES;
+------------------+
| Tables_in_glance |
+------------------+
| image_locations  |
| image_members    |
| image_properties |
| image_tags       |
| images           |
| migrate_version  |
| task_info        |
| tasks            |
+------------------+
8 rows in set (0.00 sec)


mysql> SELECT * FROM images
    -> ;
+--------------------------------------+------------------+---------+--------+-----------+---------------------+---------------------+------------+---------+-------------+------------------+----------+----------------------------------+----------+---------+-----------+--------------+
| id                                   | name             | size    | status | is_public | created_at          | updated_at          | deleted_at | deleted | disk_format | container_format | checksum | owner                            | min_disk | min_ram | protected | virtual_size |
+--------------------------------------+------------------+---------+--------+-----------+---------------------+---------------------+------------+---------+-------------+------------------+----------+----------------------------------+----------+---------+-----------+--------------+
| 53c06e6d-ced7-4ee0-9a92-acfc2d8219c7 | tty-linux-kernel | 4404752 | queued |         0 | 2013-01-18 17:00:00 | 2013-01-18 17:00:00 | NULL       |       0 | aki         | aki              | NULL     | f9a70976a8064aceb3523191e03d8c1c |        0 |       0 |         0 |         NULL |
+--------------------------------------+------------------+---------+--------+-----------+---------------------+---------------------+------------+---------+-------------+------------------+----------+----------------------------------+----------+---------+-----------+--------------+
1 row in set (0.00 sec)

mysql>

root@hb067148:/tmp/images# keystone user-list
+----------------------------------+--------+---------+---------------------+
|                id                |  name  | enabled |        email        |
+----------------------------------+--------+---------+---------------------+
| 79bad95c900b4096865d9375430c82b3 | admin  |   True  |  admin@example.com |
| 05b3462f2d4b4364b163c7bed83866d8 |  demo  |   True  | demo@example.com |
| d13adb9a26d04909b16a21b977defe2a | glance |   True  |  glance@example.com |
+----------------------------------+--------+---------+---------------------+

root@hb067148:/tmp/images# cat /root/admin-openrc.sh
export OS_USERNAME=admin
export OS_PASSWORD=fcplugin
export OS_TENANT_NAME=admin
export OS_AUTH_URL=http://controller.67.148:35357/v2.0
root@hb067148:/tmp/images#

Please let me know if you need more info.

edit retag flag offensive reopen merge delete

Closed for the following reason duplicate question by koolhead17
close date 2014-08-10 16:26:38.423634

Comments

hey kindly check the fourm, this question has been answered many times before https://ask.openstack.org/en/question... I am closing it being a duplicate question.

koolhead17 gravatar imagekoolhead17 ( 2014-08-10 16:26:32 -0500 )edit
1

I am not going to reopen the question because I do agree that it has been asked many times. But he does mention he has searched the forum and has provided the appropriate information to identify the issue. So I am going to add it in a comment.

I don't think we should discourage well formated posting even if it is a fairly common issue, especially this issue since it has many many causes.

SamYaple gravatar imageSamYaple ( 2014-08-12 17:42:25 -0500 )edit
1

In your glance-registry.conf file you have your controller name wrong.

[keystone_authtoken]
auth_uri = http://controller.67.148:5000
auth_host = controller

Should be

[keystone_authtoken]
auth_uri = http://controller.67.148:5000
auth_host = controller.67.148

According to your export information. Looks like a simple typo, happend all the time. Make the change and restart the glance services. Should work from there.

SamYaple gravatar imageSamYaple ( 2014-08-12 17:44:12 -0500 )edit

Yup this solved the issue. Thanks!!

humblearner gravatar imagehumblearner ( 2014-08-12 17:49:50 -0500 )edit

Thank you for having such a detailed well formated question. It was very easy to see the problem thanks to that!

SamYaple gravatar imageSamYaple ( 2014-08-12 17:57:03 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
2

answered 2014-08-08 00:49:34 -0500

raiesmh08 gravatar image

updated 2014-08-12 17:37:58 -0500

SamYaple gravatar image

Problem seems from keystone authentication.

I suggest, try to validate keystone installation. And if that is not working fine and you are on development environment then you can drop and flush database of glance and keystone and again configure databases for both of them.

During this activity, ensure that you have run command to sync database like -

# su -s /bin/sh -c "glance-manage db_sync" glance

and

# su -s /bin/sh -c "keystone-manage db_sync" keystone

Probably this can help you.

edit flag offensive delete link more

Comments

this helped great thanks!

Moe gravatar imageMoe ( 2014-12-29 00:01:39 -0500 )edit

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-08-07 23:40:24 -0500

Seen: 6,655 times

Last updated: Aug 12 '14