How to configure transparent proxy in openstack [closed]

asked 2014-08-07 13:58:44 -0600

Doria gravatar image

updated 2014-08-08 15:34:42 -0600

smaffulli gravatar image

My openstack environment: ICEHOUSE on UBUNTU 14.04 server Controller node; network node; compute node. Neutron GRE mode.

I setup an instance, configured it as the gateway of another instance (USER). I have also configured the GATEWAY instance as a transparent proxy using squid. However, when I execute the wget command in USER, 200 OK is returned but there is no download speed.

In the access log of the squid server, "TCP_MISS_ABORTED" are found.

If I did not configure the transparent proxy on the GATEWAY, wget succeeded. Both the GATEWAY AND USER are using fixed ip addresses, no floating ip assigned.

securitygroup rule on USER and GATEWAY:
ALLOW IPv4 1-65535/tcp to 0.0.0.0/0
ALLOW IPv4 icmp from 0.0.0.0/0
ALLOW IPv4 1-65535/tcp from 0.0.0.0/0
ALLOW IPv4 1-65535/udp from 0.0.0.0/0
ALLOW IPv4 1-65535/udp to 0.0.0.0/0

I'm sure the squid transparent proxy is configured correctly, since I've tested out of the openstack environment. I'm thinking whether there is some rules related to http proxy in openstack that prevents things working.

Any help will be appreciated.

edit retag flag offensive reopen merge delete

Closed for the following reason duplicate question by Doria
close date 2014-08-14 11:26:39.658379

Comments

Openstack supports transparent proxy, there is no trick here. It's actually related to my another question "wget problem in openstack"

Doria ( 2014-08-14 11:32:49 -0600 )edit