Ask Your Question
0

DHCP port binding fails on flat provider network

asked 2014-08-07 04:33:14 -0500

Sam Whitlock gravatar image

updated 2014-08-07 08:41:12 -0500

I have a flat provider network in Neutron using the ML2 plugin. I run the DHCP plugin on the network, but the port is unknown to the agent plugin, and it gets the "dead" 4095 VLAN tag on my integration bridge.

Here is the log line on the node running the DHCP agent (from the OVS Neutron agent trying to configure the port):

WARNING neutron.plugins.openvswitch.agent.ovs_neutron_agent [-] Device 66b395cc-86e9-4cf4-8e0c-49df157fd887 not defined on plugin

When I look at Neutron Server, I see the following log message

 WARNING neutron.plugins.ml2.rpc [req-000dd350-72fe-4da7-9064-726890c9d75c None None] Device 66b395cc-86e9-4cf4-8e0c-49df157fd887 requested by agent ovs66201834824c on network e2a8d8b6-2fac-47f0-8982-9da41f4838c2 not bound, vif_type: binding_failed

I'm trying to track down how this happens, and I think it is a configuration bug somewhere, but I'm not sure where to look.

I can add more logging and configuration to this question, but I'm not sure which is relevant.

  • http://paste.openstack.org/show/91436/ (neutron.conf)
  • http://paste.openstack.org/show/91438/ (ml2_conf.ini)
  • http://paste.openstack.org/show/91439/ (dhcp_agent.ini)

A note about the setup: my machines have a management network (on eth0) and a data network (on a port called cu1, which is bridged in my configs as br-cu1; this is usually know as br-ex in other folks' configs).

I'm set up the network initially with Devstack, but I have modified it since then. I create the sole provider network with

neutron net-create --provider:network_type=flat --provider:physical_network=physnet1 --router:external=true public-net --shared

and I create the sole subnet with

neutron subnet-create  --no-gateway --enable-dhcp --allocation-pool=start=192.168.10.100,end=192.168.10.200 --name public-subnet public-net 192.168.0.0/16

Thanks in advance!

edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
0

answered 2014-08-07 09:04:06 -0500

Sam Whitlock gravatar image

Well, I fixed it, but I don't know why it works. I added the following lines to ml2_conf.ini:

[ovs]
bridge_mappings = physnet1:br-cu1

[ml2_type_flat]
flat_networks = *

I don't know _if_ this was the reason, or if I just restarted it the magic numbers of times to avoid hitting some race condition.

If someone has a better explanation (_i.e._, any explanation), I would appreciate your insights.

edit flag offensive delete link more

Comments

I literally just googled this error and got my own answer again! Thanks, me from the past!

Sam Whitlock gravatar imageSam Whitlock ( 2015-02-17 10:33:22 -0500 )edit
0

answered 2014-08-27 04:32:16 -0500

LainesStack gravatar image

Hello im facing exactly the same issue, unfortunately my ml2_conf.ini looking fine.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

2 followers

Stats

Asked: 2014-08-07 04:22:42 -0500

Seen: 3,107 times

Last updated: Aug 27 '14