Ask Your Question
1

Unable to install Keystone on Ubuntu 14.04 [closed]

asked 2014-08-06 10:31:45 -0500

I am unable to install Keystone on my Ubuntu 14.04.

Error after running apt-get install keynote

Setting up keystone (1:2014.1.1-0ubuntu1) ...
Traceback (most recent call last):
  File "/usr/bin/keystone-manage", line 37, in <module>
    from keystone import cli
  File "/usr/lib/python2.7/dist-packages/keystone/cli.py", line 22, in <module>
    from keystone.common import openssl
  File "/usr/lib/python2.7/dist-packages/keystone/common/openssl.py", line 18, in <module>
    from keystone.common import environment
  File "/usr/lib/python2.7/dist-packages/keystone/common/environment/__init__.py", line 20, in <module>
    from keystone.openstack.common import log
  File "/usr/lib/python2.7/dist-packages/keystone/openstack/common/log.py", line 435, in <module>
    class LogConfigError(Exception):
  File "/usr/lib/python2.7/dist-packages/keystone/openstack/common/log.py", line 437, in LogConfigError
    message = _('Error loading logging config %(log_config)s: %(err_msg)s')
  File "/usr/lib/python2.7/dist-packages/keystone/openstack/common/gettextutils.py", line 68, in _
    return Message(msg, domain='keystone')
  File "/usr/lib/python2.7/dist-packages/keystone/openstack/common/gettextutils.py", line 168, in __new__
    msgtext = Message._translate_msgid(msgid, domain)
  File "/usr/lib/python2.7/dist-packages/keystone/openstack/common/gettextutils.py", line 207, in _translate_msgid
    system_locale = locale.getdefaultlocale()
  File "/usr/lib/python2.7/locale.py", line 543, in getdefaultlocale
    return _parse_localename(localename)
  File "/usr/lib/python2.7/locale.py", line 475, in _parse_localename
    raise ValueError, 'unknown locale: %s' % localename
ValueError: unknown locale: UTF-8
dpkg: error processing package keystone (--configure):
 subprocess installed post-installation script returned error exit status 1
Processing triggers for libc-bin (2.19-0ubuntu6.1) ...
Processing triggers for ureadahead (0.100.0-16) ...
Errors were encountered while processing:
 keystone
E: Sub-process /usr/bin/dpkg returned an error code (1)

output of apt-get install -f

Reading package lists... Done
Building dependency tree       
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 3 not upgraded.
1 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
    LANGUAGE = "en_IN:en",
    LC_ALL = (unset),
    LC_CTYPE = "UTF-8",
    LANG = "en_IN"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
Setting up keystone (1:2014.1.1-0ubuntu1) ...
Traceback (most recent call last):
  File "/usr/bin/keystone-manage", line 37, in <module>
    from keystone import cli
  File "/usr/lib/python2.7/dist-packages/keystone/cli.py", line 22, in <module>
    from keystone.common import openssl
  File "/usr/lib/python2.7/dist-packages/keystone/common/openssl.py", line 18, in <module>
    from keystone.common import environment
  File "/usr/lib/python2.7/dist-packages/keystone/common/environment/__init__.py", line 20, in <module>
    from keystone.openstack.common import log
  File "/usr/lib/python2.7/dist-packages/keystone/openstack/common/log.py", line 435, in <module>
    class LogConfigError(Exception):
  File "/usr/lib/python2.7/dist-packages/keystone/openstack/common/log.py", line ...
(more)
edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by koolhead17
close date 2014-08-10 17:28:34.440335

2 answers

Sort by ยป oldest newest most voted
1

answered 2014-08-07 06:26:05 -0500

export LANGUAGE=en_US.UTF-8 export LANG=en_US.UTF-8 export LC_ALL=en_US.UTF-8 locale-gen en_US.UTF-8 dpkg-reconfigure locales

is the solution worked for me.

edit flag offensive delete link more
0

answered 2014-08-07 04:10:08 -0500

foexle gravatar image

Hi,

try echo "en_US.UTF-8 UTF-8" > /var/lib/locales/supported.d/local dpkg-reconfigure locales

Cheers Heiko

edit flag offensive delete link more

Comments

same problem sadly.

Gursimran Singh gravatar imageGursimran Singh ( 2014-08-07 05:39:27 -0500 )edit

sorry en_IN.UTF-8 UTF-8

foexle gravatar imagefoexle ( 2014-08-07 05:51:47 -0500 )edit

thanks for pointing our the problem with locals. It worked out in other way, thanks a ton!

Gursimran Singh gravatar imageGursimran Singh ( 2014-08-07 06:25:48 -0500 )edit

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-08-06 10:31:45 -0500

Seen: 2,733 times

Last updated: Aug 07 '14