Ask Your Question
0

glance-api fails to install on grizzly

asked 2013-04-23 00:29:59 -0600

sandeep-raman gravatar image

updated 2013-04-23 04:45:13 -0600

Since last week, glance-api2013.1-0ubuntu1~cloud0all.deb fails to install via apt-get or dpkg or gdebi.

With apt-get the error is Failed to fetch http://ubuntu-cloud.archive.canonical.com/ubuntu/pool/main/g/glance/glance-api_2013.1-0ubuntu1~cloud0_all.deb (http://ubuntu-cloud.archive.canonical.com/ubuntu/pool/main/g/glance/glance-api2013.1-0ubuntu1~cloud0all.deb) Hash Sum mismatch

With dpkg or gdebi -

gdebi glance-api2013.1-0ubuntu1~cloud0all.deb

Unpacking glance-api (from glance-api2013.1-0ubuntu1~cloud0all.deb) ... dpkg-deb (subprocess): data: internal gzip read error: '<fd:4>: data error' dpkg-deb: error: subprocess <decompress> returned error exit status 2 dpkg: error processing glance-api2013.1-0ubuntu1~cloud0all.deb (--install): corrupted filesystem tarfile - corrupted package archive Processing triggers for ureadahead ... Processing triggers for man-db ... Errors were encountered while processing: glance-api2013.1-0ubuntu1~cloud0all.deb

Is anyone else seeing this problem? Looks like a packaging issue?

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2013-04-24 05:55:55 -0600

sandeep-raman gravatar image

It is a proxy cache issue. Changing the proxy, downloading glance packages and manual install worked.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

Stats

Asked: 2013-04-23 00:29:59 -0600

Seen: 147 times

Last updated: Apr 24 '13