Ask Your Question
2

keystone is not working after moving to v2 from v3.

asked 2014-08-04 11:19:55 -0500

DeepVish gravatar image

Hello, I had working setup of keystone V2. Then i moved to V3 on same setup for some exploration. Now when i again moved to V2 i am getting following error during user/tenant create/list

[root@swiftProxyNode tmp]# keystone --debug  user-create --name admin --pass Passw0rd
REQ: curl -i -X POST http://127.0.0.1:5000/v2/users -H "User-Agent: python-keystoneclient" -H "Content-Type: application/json" -H "X-Auth-Token: 71da1713141f49744207"
REQ BODY: {"user": {"email": null, "password": "Passw0rd", "enabled": true, "name": "admin", "tenantId": null}}

RESP: [404] {'date': 'Mon, 04 Aug 2014 04:02:05 GMT', 'content-type': 'application/json', 'content-length': '93', 'vary': 'X-Auth-Token'}
RESP BODY: {"error": {"message": "The resource could not be found.", "code": 404, "title": "Not Found"}}

Request returned failure status: 404
The resource could not be found. (HTTP 404)

Logs from /var/log/keystone/keystone.log

2014-08-04 09:32:05.225 22187 DEBUG routes.middleware [-] No route matched for POST /v2/users __call__ /usr/lib/python2.6/site-packages/Routes-1.12.3-py2.6.egg/routes/middleware.py:97
2014-08-04 09:32:05.226 22187 INFO access [-] 127.0.0.1 - - [04/Aug/2014:04:02:05 +0000] "POST http://127.0.0.1:5000/v2/users HTTP/1.0" 404 93
2014-08-04 09:32:05.227 22187 INFO eventlet.wsgi.server [-] 127.0.0.1 - - [04/Aug/2014 09:32:05] "POST /v2/users HTTP/1.1" 404 228 0.002062

2014-08-04 09:42:56.353 22187 DEBUG routes.middleware [-] No route matched for GET /v2/users __call__ /usr/lib/python2.6/site-packages/Routes-1.12.3-py2.6.egg/routes/middleware.py:97
2014-08-04 09:42:56.354 22187 INFO access [-] 127.0.0.1 - - [04/Aug/2014:04:12:56 +0000] "GET http://127.0.0.1:5000/v2/users HTTP/1.0" 404 93
2014-08-04 09:42:56.355 22187 INFO eventlet.wsgi.server [-] 127.0.0.1 - - [04/Aug/2014 09:42:56] "GET /v2/users HTTP/1.1" 404 228 0.001971

I even tried creating keystone database again but no luck. Any idea what i am missing here?

edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
3

answered 2014-08-04 11:26:59 -0500

updated 2014-08-04 11:39:27 -0500

Your url is wrong. It should be http://127.0.0.1:5000/v2.0/users for v2. (i.e) v2.0 instead of v2.

edit flag offensive delete link more

Comments

Thank you for answer. it worked after changing url to http://127.0.0.1:35357/v2.0/users

It does not work with port number 5000. hence changed port number to 35357 in url. after that it worked.

DeepVish gravatar imageDeepVish ( 2014-08-04 11:33:45 -0500 )edit

afair 5000 is publicURL and 35357 is internalURL. It depends on how it's configured in your case, but check again your config and ports on which the service is listening.

semyazz gravatar imagesemyazz ( 2014-08-04 14:14:28 -0500 )edit

In V2.0 only token operations are exposed on public url. All other operations are at admin url. In v3, all the operations are available at both the ports. You are better off just using 35357 which is default admin endpoint port

Haneef Ali gravatar imageHaneef Ali ( 2014-08-05 00:48:13 -0500 )edit
0

answered 2014-09-29 04:24:53 -0500

sumer_link gravatar image

Deep, how did you perform the move to V3? Was it successful ? I'm struggling with it at the moment and any help is much appreciated.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-08-04 11:19:55 -0500

Seen: 1,936 times

Last updated: Sep 29 '14