Ask Your Question
0

Red Hat RDO: Horizon '/dashboard' will not load from Internet

asked 2014-08-02 13:28:26 -0500

noplacelike127 gravatar image

updated 2014-08-03 12:52:37 -0500

Hello,

First question to the OpenStack community. My apologies if it is a silly one, I've been searching around and can not figure it out.

I've installed CentOS with Red Hat's all-in-one config using these instructions: http://openstack.redhat.com/Quickstart

Things look good. It is on a KVM virtual machine hosted on a physical server in my lab. I use iptables on the physical machine to route traffic to the VM over port 80. I'm using the same rules I used on my devstack instance, which worked fine in the past. iptables -t nat -I PREROUTING -p tcp -d <mypublicip> --dport 80 -j DNAT --to-destination

I can access http://mypublicip/nagios from the Internet. That lets me log in, which tells me my iptables stuff is working properly (I assume). Also, I can access http://mypublicip and get a basic "Index" page.

However, when I try to access http://mypublicip/dashboard I get this message: The requested URL /dashboard was not found on this server.

Now, when I run 'curl http://192.168.122.250/dashboard' from my physical server inside the hosted subnet (only routing through VM network), I get a response back in text that looks like the OpenStack login dashboard.

What I've tried so far: I edited /etc/openstack-dashboard/local_settings with the following: ALLOWED_HOSTS = ['*']

And rebooted. Still the same issue.

The horizon_error.log is empty and the horizon_access.log only shows entries when I hit it with the working curl command.

If anyone has some insights, I would really appreciate it! Thank you everyone for reading.

  • Chris
edit retag flag offensive close merge delete

Comments

Maybe you have some troubles with the configuration of SELinux. Try disabling it for a moment. Change your /etc/selinux/config

#SELINUX=enforcing 
SELINUX=disabled

and than reboot the node; if, after that change, you can login in from Internet, you definitely have some troubles with the configuration on SELinux.

Antonio G. gravatar imageAntonio G. ( 2014-08-04 02:54:38 -0500 )edit

Thanks for the reply. I had already disabled SELinux prior to installing, though.

noplacelike127 gravatar imagenoplacelike127 ( 2014-08-05 10:46:54 -0500 )edit

4 answers

Sort by ยป oldest newest most voted
4

answered 2014-08-06 09:02:13 -0500

jpichon gravatar image

This reminds me of https://bugzilla.redhat.com/show_bug.... : could you see if you have "ServerAlias" defined in /etc/httpd/conf.d/openstack-dashboard.conf or etc/httpd/conf.d/15-horizon_vhost.conf ? Removing them altogether, or adding ServerAlias and restarting httpd should help I think.

edit flag offensive delete link more

Comments

1

That did the trick, thank you so much! I added a ServerAlias line to /etc/httpd/conf.d/15-horizon_vhost.conf that was the public DNS name of my server. Working like a charm. :)

noplacelike127 gravatar imagenoplacelike127 ( 2014-08-06 09:32:21 -0500 )edit

Glad this is resolved!

jpichon gravatar imagejpichon ( 2014-08-06 11:27:31 -0500 )edit

Worked Great. Thanks

Khayam gravatar imageKhayam ( 2015-07-04 08:53:28 -0500 )edit
1

answered 2018-02-04 23:02:52 -0500

uchihaitachi gravatar image

Check whether you have the following line in your /etc/httpd/conf.d/openstack-dashboard.conf. . WSGIApplicationGroup %{GLOBAL} Because I also faced some problems with Openstack dashboard and it happened that the above line was missing. Once the above line was included in the /etc/httpd/conf.d/openstack-dashboard.conf file the problem was solved. And also check whether your firewall allow the ports.

edit flag offensive delete link more

Comments

Thank you, worked with CentOS!

nanasidaniel gravatar imagenanasidaniel ( 2018-10-02 07:34:12 -0500 )edit
0

answered 2014-08-04 20:54:59 -0500

Can you authenticate using Keystone from your terminal? Also make sure you can resolve FQDN?

We are able to view Horizon & authenticate to Keystone over VPN at all client sites for Grizzly, Havanna & IceHouse.

Sounds like a DNS or Firewall issue; make sure you can perform a nslookup & reverse nslookup from each nameserver... and verify you can hit other nodes in the same range by IP & that the respective ports are open for ingress.

Anything in logs?

edit flag offensive delete link more

Comments

I don't think it was related to the firewall as I have no problem access the /nagios directory over the web. And there are no other nodes - it is a single node install. DNS is working fine.

I've given up for now and gone back to devstack on Ubuntu for testing, as that works without issue.

Thanks everyone!

noplacelike127 gravatar imagenoplacelike127 ( 2014-08-05 10:48:55 -0500 )edit
0

answered 2014-08-03 07:20:01 -0500

Jakub gravatar image

Have you set OPENSTACK_HOST = ip address inside of local_settings?

edit flag offensive delete link more

Comments

It was not set. I just tried setting it to 127.0.0.1 and then to the public IP of the physical machine when that did not work. I restarted httpd after each change, but this did not solve the problem.

Note that the login page DOES work, but only from the physical KVM host or from localhost inside the VM.

Thanks for the reply!

noplacelike127 gravatar imagenoplacelike127 ( 2014-08-03 12:54:02 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-08-02 13:28:26 -0500

Seen: 12,713 times

Last updated: Aug 06 '14