Ask Your Question

Heat error: "image 'NoneType' object has no attribute 'rstrip'"

asked 2014-08-01 09:10:00 -0500

semyazz gravatar image

updated 2014-08-13 16:21:39 -0500

zaneb gravatar image

I'm facing the following error in Heat:

ERROR: Property error : server1: image 'NoneType' object has no attribute 'rstrip'


2014-08-01 16:02:26.031 9086 TRACE heat.engine.parser     raise exception.StackValidationFailed(message=msg)
2014-08-01 16:02:26.031 9086 TRACE heat.engine.parser StackValidationFailed: Property error : server1: image 'NoneType' object has no attribute 'rstrip'

using the following template

heat_template_version: 2013-05-23
description: Test Template
    type: string
    description: Image use to boot a server
    type: string
    description: Network ID for the server
    type: OS::Nova::Server
      name: "Testserver"
      image: { get_param: ImageID }
      flavor: "m1.tiny"
      - network: { get_param: NetID }
    description: IP address of the server in the private network
    value: { get_attr: [ server1, first_address ] }

I tried UUID, Name in image property. Nothing helps. Is there anyone who can take a quick look and tell me what is wrong with that template? heat validate-template says it's ok.

edit retag flag offensive close merge delete


Could you paste the output of keystone catalog?

I wonder if a None endpoint is being passed to glanceclient concat_url

Steve Baker gravatar imageSteve Baker ( 2014-08-03 16:42:41 -0500 )edit

catalog looks fine. I have glance endpoints and I'm able to launch instance, so to me it's fine. I have a feeling it has something to do with the permissions and users. I tried devstack on Ubuntu 14.04 Server amd64 on my VirtualBox and it works fine,but Ubuntu has 2014.2 and I have 2014.1.1 - debian

semyazz gravatar imagesemyazz ( 2014-08-04 14:09:17 -0500 )edit

till the end of the week I'll try to install 2014.2 or at least 2014.1.2 from icehouse and try it again and if that won't help I'll try to dig into the code and find out that exception, but still I would prefer to install it from debian's repository

semyazz gravatar imagesemyazz ( 2014-08-04 14:12:14 -0500 )edit

Have exactly the same problem

foexle gravatar imagefoexle ( 2014-08-08 06:19:42 -0500 )edit

I have the same problem too!!! I updated from Havana to Icehouse ... I don't remember last time it worked but I know it have the same error message with 2014.1.2!

StackValidationFailed_Remote: Property error : WikiDatabase: ImageId 'NoneType' object has no attribute 'rstrip' Traceback (most recent call last):

David Hill gravatar imageDavid Hill ( 2014-08-23 04:33:39 -0500 )edit

4 answers

Sort by ยป oldest newest most voted

answered 2014-08-25 09:50:37 -0500

David Hill gravatar image

Make sure you have authurl in your api-paste.ini.

'[pipeline:heat-api] pipeline = faultwrap versionnegotiation authurl authtoken context apiv1app

[pipeline:heat-api-standalone] pipeline = faultwrap versionnegotiation authurl authpassword context apiv1app'

edit flag offensive delete link more


everything is fine with api-paste.ini

semyazz gravatar imagesemyazz ( 2014-09-17 09:04:42 -0500 )edit

answered 2014-08-13 16:20:35 -0500

zaneb gravatar image

It's possible this is due to a configuration issue:

edit flag offensive delete link more


It's an old issue (2013). Moreover authentication driver is different in Icehouse and it's not "heat.common.auth_token:filter_factory" anymore, so it's a completely wrong advice. The default value from packages is correct (it starts with keystone...)

semyazz gravatar imagesemyazz ( 2014-08-25 03:42:02 -0500 )edit

[filter:authtoken] paste.filter_factory = keystoneclient.middleware.auth_token:filter_factory

David Hill gravatar imageDavid Hill ( 2014-08-25 09:48:52 -0500 )edit

answered 2014-08-13 16:14:42 -0500

pas-ha gravatar image

possible reason - misconfigured config files.

Does answer on help?

edit flag offensive delete link more


Link doesn't work.

semyazz gravatar imagesemyazz ( 2014-08-25 03:39:54 -0500 )edit

Im pretty sure the problem is not the configuration. I`ve followed every single steps in the manual ( ) like many other people.

David Hill gravatar imageDavid Hill ( 2014-08-25 09:47:53 -0500 )edit

Get to know Ask OpenStack

Resources for moderators

Question Tools



Asked: 2014-08-01 09:10:00 -0500

Seen: 1,525 times

Last updated: Aug 25 '14