Ask Your Question
2

neutron agents-list is empty!!

asked 2014-07-31 17:10:50 -0500

yumdork gravatar image

I strictly followed the openstack-install-guide-yum-icehouse document step by step . Finally all services are up,but when i checked the agent-l3.log ,it says that can't find l3 agent (as well as dhcp agent). Then i checked mysql database with the truth that table agents of neutron is really empty. I turned on the mysql logs, spending whole night to reinstall neutron with a fact that nothing about inserting entries into the agents at all.shocked! I sincerly ask for your help ! but now,i need to get some sleep. thanks.

edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
1

answered 2014-07-31 18:01:17 -0500

rooter gravatar image

Do you have a single or multi node deployment? Check the logs on the nodes hosting the agents. is the message service (rabbit/qpid) working? That's how agents announce their presence to the neutron-server.

edit flag offensive delete link more

Comments

Thank you for your answer . the l3-agent.log has two kinds of errors

  1. router Synchronized failed because of rpc errors
  2. operational error:no such table:agents . u 'SELECT agents.id....from agents where agents.TYPE=? AND agents.host=?' if as you said,it must give a connection error.But none
yumdork gravatar imageyumdork ( 2014-07-31 23:44:36 -0500 )edit

my rabbitmq is working properly but neutron agent-list returns nothing althogh there are 2 neutron-l2-plugin and a dhcp and a l3 agent.

my error is :

2014-12-07 23:37:43.219 8965 ERROR oslo.messaging._drivers.common [req-1fc872e9-3632-4af3-8330-8d1714aaffe4 ] Returning exception Agent with age
Moe gravatar imageMoe ( 2014-12-07 05:55:04 -0500 )edit

how can i solve the sycronizing problem

Moe gravatar imageMoe ( 2014-12-07 05:55:49 -0500 )edit

were you able to resolve this issue. I am using Openstack juno release and encountering similar issue if it is resolved is it something which you could share. I know 9 months ago

adendukuri gravatar imageadendukuri ( 2015-05-11 11:07:47 -0500 )edit
2

answered 2015-10-19 13:12:23 -0500

Malinoski gravatar image

In my case, the ntp service in the network node was down (dont know why). I just reboot the ntp service (service ntp restart) and the command "neutron agent-list" came back to work!

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-07-31 17:09:08 -0500

Seen: 1,487 times

Last updated: Jul 31 '14