icehouse neutron

asked 2014-07-30 13:39:07 -0500

ospz2014 gravatar image

updated 2014-07-30 14:11:23 -0500

HI 
I am facing issue, where my instances are able to connect on network - 

Below is my instance log, so seems something to do with config, instance doesnt connect to physical nic ? 

info: initramfs: up at 2.11
NOCHANGE: partition 1 is size 2072385. it cannot be grown
info: initramfs loading root from /dev/vda1
info: /etc/init.d/rc.sysinit: up at 3.07
Starting logging: OK
Initializing random number generator... done.
Starting acpid: OK
cirros-ds 'local' up at 4.18
no results found for mode=local. up 4.45. searched: nocloud configdrive ec2
Starting network...
udhcpc (v1.20.1) started
Sending discover...
Sending select for 10.40.125.144...
Lease of 10.40.125.144 obtained, lease time 600
deleting routers
route: SIOCDELRT: No such process
adding dns 171.70.168.183
adding dns 173.36.131.10
adding dns 173.37.87.157
cirros-ds 'net' up at 5.15
checking http://169.254.169.254/2009-04-04/instance-id
failed 1/20: up 5.34. request failed
failed 2/20: up 10.55. request failed
failed 3/20: up 13.54. request failed
failed 4/20: up 18.70. request failed
failed 5/20: up 21.69. request failed

*** 

neutron.conf 

[DEFAULT]
debug = True
core_plugin = neutron.plugins.ml2.plugin.Ml2Plugin
allow_overlapping_ips = False
notification_driver=neutron.openstack.common.notifier.rpc_notifier
rpc_backend=neutron.openstack.common.rpc.impl_kombu
rabbit_host = 10.40.123.138
ovs_use_veth = true
control_exchange = neutron
api_workers = 32
agent_down_time = 60
mac_generation_retries = 16
bind_host = 10.40.123.138
bind_port = 9696
notify_nova_on_port_status_changes = True
notify_nova_on_port_data_changes = True
nova_url = http://svl-aci-ost-3.cisco.com:8774/v2
nova_region_name = regionOne
nova_admin_username = nova
nova_admin_tenant_id = services
nova_admin_password = xxxxxxxx
nova_admin_auth_url = http://svl-aci-ost-3.cisco.com:35357/v2.0
dhcp_lease_duration = 600
dhcp_lease_time = 600
force_dhcp_release = True
[keystone_authtoken]
auth_uri = http://10.40.123.138:5000
auth_host = 10.40.123.138
auth_port = 35357
auth_protocol = http
admin_tenant_name = services
admin_user = neutron
admin_password = xxxxxxxx
signing_dir = /var/lib/neutron/keystone-signing
[database]
sql_connection = mysql://neutron:neutron_pass@10.40.123.138/neutron_ml2
[AGENT]
root_helper = sudo neutron-rootwrap /etc/neutron/rootwrap.conf
report_interval = 28

**** 
ml2_conf.ini / plugin.ini - 

[ml2]
type_drivers = vlan,local,flat
tenant_network_type = vlan,local,flat
mechanism_drivers = openvswitch
[securitygroup]
enable_security_group = True
firewall_driver = neutron.agent.linux.iptables_firewall.OVSHybridIptablesFirewallDriver
[ovs]
enable_tunneling = False
local_ip = 10.40.123.138
network_vlan_ranges = physnet1:1:1000
bridge_mappings = physnet1:br-ens224
[agent]
get_datapath_retry_times = 60
[LINUX_BRIDGE]
bridge_mappings = physnet1:br-ens224
[ml2_type_vlan]
network_vlan_ranges = physnet1:1:1000

*** 

Instance is also not connecting to metadata host, obvious as it is not on network .. 

neutron net-show ext-net
+---------------------------+--------------------------------------+
| Field                     | Value                                |
+---------------------------+--------------------------------------+
| admin_state_up            | True                                 |
| id                        | c26448d1-c441-43f6-90b1-ced10547592f |
| name                      | ext-net                              |
| provider:network_type     | local                                |
| provider:physical_network |                                      |
| provider:segmentation_id  |                                      |
| router:external           | True                                 |
| shared                    | True                                 |
| status                    | ACTIVE                               |
| subnets                   | 8929a924-dda0-4d83-bc9a-799669683cd1 |
| tenant_id                 | 06af74704bbf44b7b4ff701620875648     |
+---------------------------+--------------------------------------+
[root@svl-aci-ost-3 ml2(keystone_admin)]# neutron subnet-show ext-net
+------------------+----------------------------------------------------------+
| Field            | Value                                                    |
+------------------+----------------------------------------------------------+
| allocation_pools | {"start": "10.40.125.133", "end": "10.40.125.160"}       |
| cidr             | 10.40.125.128/25                                         |
| dns_nameservers  | 171.70.168.183                                           |
|                  | 173.36.131.10                                            |
|                  | 173.37.87.157                                            |
| enable_dhcp      | True                                                     |
| gateway_ip       | 10.40.125.129                                            |
| host_routes      | {"destination": "0.0.0.0/0", "nexthop": "10.40.125.129"} |
| id               | 8929a924-dda0-4d83-bc9a-799669683cd1                     |
| ip_version       | 4                                                        |
| name             | ext-net                                                  |
| network_id       | c26448d1-c441-43f6-90b1-ced10547592f                     |
| tenant_id        | 06af74704bbf44b7b4ff701620875648                         |
+------------------+----------------------------------------------------------+
edit retag flag offensive close merge delete

Comments

1

try to use the proper syntax when you post to make it ease to read: markdown is fairly simple to grasp and there is a live preview on the page (below the entry)

smaffulli gravatar imagesmaffulli ( 2014-07-30 13:55:07 -0500 )edit

please update with the following -

compute node and neutron

ovs-vsctl show

ifconfig

nfv-zombie gravatar imagenfv-zombie ( 2015-04-22 09:19:31 -0500 )edit