Ask Your Question
0

WARNING: Bypassing authentication using a token & endpoint (authentication credentials are being ignored)

asked 2014-07-30 05:02:53 -0500

Robert gravatar image

updated 2014-07-31 04:13:27 -0500

I am trying to install OpenStack on virtulized Ubuntu on Windows host. I am following this instalation: http://docs.openstack.org/icehouse/in...

So fare I have installed keystone en set up some credentials and I am moving on with glance installation:

$ export OS_SERVICE_TOKEN=43beada85170163c97e1
$ export OS_SERVICE_ENDPOINT=http://controller:35357/v2.0

and I have also source admin-openrc.sh which looks like:

export OS_USERNAME=admin
export OS_PASSWORD=adminpass  
export OS_TENANT_NAME=admin
export OS_AUTH_URL=http://controller:35357/v2.0

What actualy this warning means?

WARNING: Bypassing authentication using a token & endpoint (authentication credentials are being ignored)
edit retag flag offensive close merge delete

3 answers

Sort by ยป oldest newest most voted
2

answered 2014-07-30 05:59:00 -0500

I think that as you set up both auth method, it is using the first one (as more general). If you unset OS_SERVICE_TOKEN and OS_SERVICE_ENDPOINT, sourcing the rc file again, I think you could give commands as admin user using rc file credentials.

edit flag offensive delete link more

Comments

I have tunseted OS_SERVICE_TOKEN and OS_SERVICE_ENDPOINT and just used admin-openrc.sh and there is no warning. It works fine. But I remember that I have using instruction keystone user-list without OS_SERVICE_TOKEN and OS_SERVICE_ENDPOINT and I have sourced admin-openrc.sh. Then I have been asked for --os-auth-url and --os-admin or something like that. When I use CLI for some service (keystone, nova, etc) how do which authentication info (--os-username, --os-password, --os-service-token) should I use? Is there any reference of that?

Robert gravatar imageRobert ( 2014-07-30 08:19:55 -0500 )edit

Try reading this. You could generally use CLIs with user generally referred to as 'admin' user in installation guides.

Antonio G. gravatar imageAntonio G. ( 2014-07-30 08:46:57 -0500 )edit

Oke. I am runing OpenStack on Ubuntu on ESXi5 on my laptop. Now I have rebot ubuntu system. After that I just check command keystone user-list. I get Expecting an auth URL via either --os-auth-url or env[OS_AUTH_URL]. Then I sourced admin-openrc.sh in run same command and I get error Your are not authorized to perform the requested action, admin_required. (HTTP 403). Then I have export my OS_SERVICE_TOKEN and OS_SERVICE_ENDPOINT once again reun command and I get my list with this warning.

Robert gravatar imageRobert ( 2014-07-30 09:21:45 -0500 )edit

I think your admin user has not the admin role assigned. Try to follow this part of the installation guide.

You must first create an admin role with keystone role-create --name=admin (if you did not already perform this step) and then assign it to admin user with keystone user-role-add --user=admin --tenant=admin --role=admin

Antonio G. gravatar imageAntonio G. ( 2014-07-30 09:48:42 -0500 )edit

Edit the question to add more details, make it richer and readable at first glance. Comments are bad at that. Read the FAQ

smaffulli gravatar imagesmaffulli ( 2014-07-30 14:09:04 -0500 )edit
1

answered 2016-01-27 08:03:02 -0500

jckreddy gravatar image

Hi

initially We do authentication with token and once keystone service is installed we have to unset the OS_SERVICE_TOKEN using the following command "unset OS_SERVICE_TOKEN" and start using the admin-openrc.sh by sourcing this file you can have admin privileges but as you are trying to use both token and admin variables at a time it is considering the first method that is token based and bypassing the authentication credentials error will be thrown

edit flag offensive delete link more
0

answered 2015-09-11 08:19:19 -0500

Radhakrishnan Rk gravatar image

updated 2015-09-11 08:20:09 -0500

hi,

This is not a major issue..unset your environmental variables OS_SERVICE_TOKEN and OS_SERVICE_ENDPOINT

Source your admin-openrc.sh file which contains your openstack credentials.

Edit the /etc/keystone/keystone-paste.ini file and remove admin_token_auth from the [pipeline:public_api], [pipeline:admin_api], and [pipeline:api_v3] sections.

Restart your identity service..

thanks, krishnaa

edit flag offensive delete link more

Comments

@krishnaa:Thank u, it worked out :)............ I was able to solve this issue!!

surabhi gravatar imagesurabhi ( 2017-03-30 00:46:57 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-07-30 05:02:53 -0500

Seen: 4,470 times

Last updated: Sep 11 '15