Ask Your Question
0

novnc Access Not Working via Horizon in Icehouse [closed]

asked 2014-07-29 22:45:09 -0600

loopback127 gravatar image

I am unable to get console access to work when via links provided by Horizon. When I go to view an instance, open the console tab, and then click "Click here to show only console" I am directed to a URL that resembles the following:

http://somedomain.com:6080/vnc_auto.html?token=75b36f07-bc48-48b6-9501-a32dee8427d8&title=Console%20testing%28664122dd-66cc-465b-9210-9dc137a950bf%29

Which results in this error:

Failed to connect to server (code: 1006)

However when I run the following, using the same credentials used in horizon, I get a URL that looks like the following:

[root@controller ~]# nova get-vnc-console 664122dd-66cc-465b-9210-9dc137a950bf novnc
+-------+-----------------------------------------------------------------------------------------+
| Type  | Url                                                                                     |
+-------+-----------------------------------------------------------------------------------------+
| novnc | http://somedomain.com.com:6080/vnc_auto.html?token=c395ff80-24a0-4daa-af9a-9835538251d5 |
+-------+-----------------------------------------------------------------------------------------

Which leads to a functioning console.

The following is the nova.conf for my controller/vncproxy node

[DEFAULT]
rpc_backend = qpid
qpid_hostname = controller
my_ip = 10.0.0.11
vncserver_listen = 10.0.0.11
vncserver_proxyclient_address = 10.0.0.11
auth_strategy = keystone
network_api_class = nova.network.neutronv2.api.API
neutron_url = http://controller:9696
neutron_auth_strategy = keystone
neutron_admin_tenant_name = service
neutron_admin_username = neutron
neutron_admin_password = pass
neutron_admin_auth_url = http://controller:35357/v2.0
linuxnet_interface_driver = nova.network.linux_net.LinuxOVSInterfaceDriver
firewall_driver = nova.virt.firewall.NoopFirewallDriver
security_group_api = neutron
service_neutron_metadata_proxy = true
neutron_metadata_proxy_shared_secret = pass

And here is the configuration for the computer node in question:

[DEFAULT]
auth_strategy = keystone
rpc_backend = qpid
qpid_hostname = controller
my_ip = 10.0.0.31
vnc_enabled = True
vncserver_listen = 0.0.0.0
vncserver_proxyclient_address = 10.0.0.31
novncproxy_base_url = http://somedomain.com:6080/vnc_auto.html
glance_host = controller
network_api_class = nova.network.neutronv2.api.API
neutron_url = http://controller:9696
neutron_auth_strategy = keystone
neutron_admin_tenant_name = service
neutron_admin_username = neutron
neutron_admin_password = pass
neutron_admin_auth_url = http://controller:35357/v2.0
linuxnet_interface_driver = nova.network.linux_net.LinuxOVSInterfaceDriver
firewall_driver = nova.virt.firewall.NoopFirewallDriver
security_group_api = neutron

Does anyone know why I am not getting a functioning URL from Horizon but am getting a functioning URL from nova get-vnc-console ?

Systems are Centos 6.5 RDO.

edit retag flag offensive reopen merge delete

Closed for the following reason duplicate question by rbowen
close date 2014-12-03 15:14:29.724901

Comments

Hi,

Please make sure the novncproxy_base_url is accessible from your network, where you are accessing the horizon. ie. http://somedomain.com

-Beny

Beny gravatar imageBeny ( 2014-07-30 00:38:37 -0600 )edit

it is accessible, the same domain is used in the URL returned by the nova get-vnc-console.

loopback127 gravatar imageloopback127 ( 2014-07-30 08:52:00 -0600 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2014-12-03 15:14:17 -0600

rbowen gravatar image

This appears to be a duplicate of https://ask.openstack.org/en/question...

edit flag offensive delete link more

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-07-29 22:45:09 -0600

Seen: 1,461 times

Last updated: Dec 03 '14