Ask Your Question
3

Is there a problem with the openstack repos?

asked 2014-07-29 15:33:39 -0500

jml9904 gravatar image

updated 2014-07-30 10:28:12 -0500

smaffulli gravatar image

Constantly fails with:

yum install http://repos.fedorapeople.org/repos/openstack/openstack-icehouse/rdo-release-icehouse-4.noarch.rpm

Loaded plugins: fastestmirror, security

Loading mirror speeds from cached hostile

 * base: mirrors.greenmountainaccess.net
 * extras: mirror.metrocast.net
 * updates: mirror.es.its.nyu.edu

    Setting up Install Process

    Cannot open: http://repos.fedorapeople.org/repos/openstack/openstack-icehouse/rdo-release-icehouse-4.noarch.rpm. Skipping.
    Error: Nothing to do

Never needed a proxy before, and other yum installs (for example, yum update) work fine without one. wget works:

# wget --no-check-certificate http://repos.fedorapeople.org/repos/openstack/openstack-icehouse/rdo-release-icehouse-4.noarch.rpm
<... snip ...>    
Connecting to repos.fedorapeople.org|152.19.134.191|:443... connected.
WARNING: cannot verify repos.fedorapeople.org’s certificate, issued by “/C=US ....”:
  Unable to locally verify the issuer’s authority.
HTTP request sent, awaiting response... 200 OK
Length: 13589 (13K) [application/x-rpm]
Saving to: “rdo-release-icehouse-4.noarch.rpm”   
100%[===============================================================================================================>] 13,589      --.-K/s   in 0.002s

Last-modified header invalid -- time-stamp ignored.
2014-07-30 07:24:03 (7.49 MB/s) - “rdo-release-icehouse-4.noarch.rpm” saved [13589/13589]

But then the packstack install fails:

# rpm -ivh rdo-release-icehouse-4.noarch.rpm
warning: rdo-release-icehouse-4.noarch.rpm: Header V4 RSA/SHA1 Signature, key ID 0e4fbd28: NOKEY
Preparing...                ########################################### [100%]
   1:rdo-release            ########################################### [100%]
[root@lglbr061 ~]# yum -y install openstack-packstack
Loaded plugins: fastestmirror, security
Loading mirror speeds from cached hostfile
 * base: mirrors.greenmountainaccess.net
 * extras: mirror.metrocast.net
 * updates: mirror.es.its.nyu.edu
foreman                                                                                                                           | 2.9 kB     00:00
foreman/primary_db                                                                                                                |  77 kB     00:00
foreman-plugins                                                                                                                   | 2.9 kB     00:00
foreman-plugins/primary_db                                                                                                        |  26 kB     00:00
http://repos.fedorapeople.org/repos/openstack/openstack-icehouse/epel-6/repodata/repomd.xml: [Errno 14] Peer cert cannot be verified or peer cert invalid
Trying other mirror.
**Error: Cannot retrieve repository metadata (repomd.xml) for repository: openstack-icehouse. Please verify its path and try again**

Added the host IP to no_proxy in yum.conf... no change... did the yum cleanup (#yum clean all && yum clean metadata && yum clean dbcache && yum makecache && yum update -y) ... didn't help... reinstalled the OS from scratch... didn't help... tried CentOS 7 instead of Centos 6.5... same problem... sigh.

Thus the suspicion regarding the repo... not sure what else this could be? Do I need to do something locally with foreman that's new? I've done this install dozens of times, never run into this problem before...

edit retag flag offensive close merge delete

Comments

Would try follow http://openstack.redhat.com/Quickstart

yum install -y http://rdo.fedorapeople.org/rdo-release.rpm
dbaxps gravatar imagedbaxps ( 2014-07-30 06:56:19 -0500 )edit

Fails the same way, unfortunately (that's how I started out). And that used to work...

jml9904 gravatar imagejml9904 ( 2014-07-30 07:02:43 -0500 )edit

Try to switch from mirrorlist to baseurl in repofiles

dbaxps gravatar imagedbaxps ( 2014-07-30 07:10:23 -0500 )edit

Rebuilding now, will try. However: https://repos.fedorapeople.org/repos/...

returns a 404 error.

https://repos.fedorapeople.org/repos/...

works... so I'm adding: https://repos.fedorapeople.org/repos/...

correct?

jml9904 gravatar imagejml9904 ( 2014-07-30 07:23:48 -0500 )edit

Correct. Please,confirm ,that switching from mirrorlist to baseurl in repofiles resolves problem.

dbaxps gravatar imagedbaxps ( 2014-07-30 07:28:30 -0500 )edit

6 answers

Sort by » oldest newest most voted
4

answered 2014-07-30 01:40:20 -0500

dbaxps gravatar image

updated 2014-07-30 10:26:07 -0500

smaffulli gravatar image

Setting the proxy inside /etc/yum.conf works immediately. Added the following line to /etc/yum.conf: proxy=http://Proxy-IP:Port

Also if you need to setup proxy env variables for general external HTTP access, you might need to adjust openstack settings to avoid the proxy for internal openstack services: https://ask.openstack.org/en/question...

edit flag offensive delete link more

Comments

The install worked correctly from home, so I have to conclude there's something going on in my organization's caching proxy, net-nanny, or other such nonsense. Thanks again to everyone who helped... off to go chase that down!

jml9904 gravatar imagejml9904 ( 2014-07-30 18:04:23 -0500 )edit

What is Proxy-IP?

jinho.shin gravatar imagejinho.shin ( 2015-02-01 01:21:12 -0500 )edit
2

answered 2014-07-29 19:23:03 -0500

smaffulli gravatar image

maybe yum wants you to specify a proxy? I'm not a yum expert, you may want to ask also on Red-Hat-specific forums

edit flag offensive delete link more
1

answered 2014-11-05 09:45:11 -0500

vguillard gravatar image

Hello,

I work with Centos6.4 and I had the same problem behind my proxy. As It worked with wget, I didn't understand why it doesn't work with the yum command.

I thing the proxy doesn't show the CA cert to the remote website, so It can't work.

I solved my problem by this way :

  1. add "sslverify=false" in /etc/yum.conf
  2. in /etc/yum.repos.d/rdo-release.repo, I set the baseurl with httpS, not http-only
  3. yum clean all && yum install openstack-packstack

I hope this could be usefull for you (or someone else)

edit flag offensive delete link more
0

answered 2014-08-04 13:43:12 -0500

rahulrajvn gravatar image

I also had the same issue. In my case date of the sever was not correct. I installed ntp and updated the time, after that it working correctly. Not sure whether it will fix your issue but if the issue still persist just give this a try.

yum -y install ntp ; service ntpd start ; chkconfig ntpd on ; yum clean all ; yum update ;

edit flag offensive delete link more

Comments

Appreciate the help, but NTP was up and running, and the times were synchronized. As the download works from home, I'm still thinking there's something up with our firewall filtering, and am ... er ... "discussing" that with our net security folks :)

jml9904 gravatar imagejml9904 ( 2014-08-04 13:46:56 -0500 )edit
0

answered 2015-03-02 12:17:27 -0500

i had to add the following:

https_proxy=https://<proxy-ip>:port export https_proxy

FINALLY got yum install -y http://rdo.fedorapeople.org/rdo-release.rpm (http://rdo.fedorapeople.org/rdo-relea...) to work after adding the https_proxy

:)

edit flag offensive delete link more
0

answered 2015-03-23 21:07:14 -0500

zaitcev gravatar image

In my case, it was the NSS getting screwed somehow. I downloaded the nss*-3.16.1-14.el6.x86_64.rpm and nspr-4.10.6-1.el6_5.x86_64.rpm, installed, and everything worked again without any tinkering with /etc/yum.conf or other.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

Stats

Asked: 2014-07-29 15:33:39 -0500

Seen: 9,496 times

Last updated: Mar 23 '15