Ask Your Question
0

Sahara: Can't login to node

asked 2014-07-28 14:11:28 -0600

datts gravatar image

updated 2014-07-28 21:38:01 -0600

Hi everyone,

I have created a cluster hadoop. I can ssh and run the simpliest MapReduce example in instances. But cluster alway just stays in "waiting" state? When i check log, see:

2014-07-24 14:20:54.906 14857 DEBUG sahara.service.engine [-] Can't login to node test-sahara-master-001 (192.168.50.168), reason AuthenticationException: Authentication failed. _wait_until_accessible /home/bkcloud/sahara-venv/local/lib/python2.7/site-packages/sahara/service/engine.py:95
2014-07-24 14:20:54.946 14857 DEBUG sahara.utils.ssh_remote [-] [test-sahara-worker-002] _execute_command took 1.2 seconds to complete _log_command /home/bkcloud/sahara-venv/local/lib/python2.7/site-packages/sahara/utils/ssh_remote.py:407
2014-07-24 14:20:54.947 14857 DEBUG sahara.service.engine [-] Can't login to node test-sahara-worker-002 (192.168.50.170), reason AuthenticationException: Authentication failed. _wait_until_accessible /home/bkcloud/sahara-venv/local/lib/python2.7/site-packages/sahara/service/engine.py:95

This is my sahara.conf:

[DEFAULT]
os_auth_host=127.0.0.1
os_auth_port=35357
os_admin_username=admin
os_admin_password=$pass
os_admin_tenant_name=admin

use_floating_ips=True
use_neutron=True
use_namespaces=False
log_dir=/var/log/sahara
log_file=sahara.log
[database]
connection=sqlite:////tmp/sahara.db
[keystone_authtoken]
auth_uri=http://127.0.0.1:5000/v2.0/
identity_uri=http://127.0.0.1:35357/

And add /usr/share/openstack-dashboard/openstack_dashboard/local/local_settings.py:

SAHARA_USE_NEUTRON = True
AUTO_ASSIGNMENT_ENABLED = False

I use plugin: http://docs.openstack.org/developer/s...

What is the problem here? Thank you very much!

edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
1

answered 2014-08-08 13:24:15 -0600

alazarev gravatar image

It looks like host where Sahara running has no access to 22 port of VMs. Please make sure that you can ssh to instances from this host.

edit flag offensive delete link more

Comments

Hi alazarev,

I still can ssh to instances and run jobs. This issue related to my questions at: https://ask.openstack.org/en/question...

P/s: Installation steps and my sahara.conf and no problems?

Thanks.

datts gravatar imagedatts ( 2014-08-11 09:16:19 -0600 )edit
1

I see that Sahara can't login to VM. So, possible problems: 1. VM is not accessible on network level (no route or closed port) 2. image is wrong (make sure you took image for right version of plugin) 3. credentials are wrong (make sure you specified correct user name in image registry)

alazarev gravatar imagealazarev ( 2014-08-11 15:55:49 -0600 )edit
1

One more possible reason: you didn't configure security group properly. You say that you can ssh to instances from the host where Sahara is installed and using the IP addresses Sahara uses to access instances. For example, in the logs you provided these are 192.168.50.170 and 192.168.50.168.

dmitrymex gravatar imagedmitrymex ( 2014-08-12 04:06:46 -0600 )edit

Thanks @alazarev and @dmitrymex,

@alazarev: You're right. I was errors at step 3: Credentials are wrong. At step "image registry", i have used file sahara-icehouse-vanilla-1.2.1-ubuntu-13.10.qcow2, but didn't specified correct user name is "ubuntu".

Now, it's worked. Thanks.

datts gravatar imagedatts ( 2014-08-13 02:42:51 -0600 )edit
0

answered 2016-05-31 00:00:09 -0600

srihitha gravatar image

Hi , Even i am facing same issue i am using this image sahara-kilo-vanilla-2.6-ubuntu-14.04.qcow2 and plugin is vanilla plugin 2.6.0 and even i gave correct username also but don't know where is the issue???please help me...

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-07-28 14:11:28 -0600

Seen: 1,551 times

Last updated: May 31 '16