Cinder multiple backends filtering

asked 2014-07-28 06:53:58 -0500

zeljko-jagust gravatar image

updated 2014-07-28 06:54:41 -0500

Hi all.

I have cinder multiple backends configured (Solidfire), but I'm not able to configure scheduler to spread volumes equally to backends when type is not specified. I have cinder filter scheduler enabled and I have set the following values in cinder configuration on both controller (cinder-api, cinder-scheduler) and compute (cinder-volume) nodes:

scheduler_default_filters = AvailabilityZoneFilter,CapacityFilter,CapabilitiesFilter scheduler_default_weighers = CapacityWeigher capacity_weight_multiplier = 1.0 volume_number_multiplier=-1.0

Regarding capacity and volume number, both values are set to spread volumes equally to backends, but what I get is stacking (opposite of what in configuration), that is all volumes are created on single same backend.

My environment is the following: OpenStack "Icehouse" running on Ubuntu 14.04 (Controller node + Network node + 4 x Compute nodes) Two SolidFire backends both having 5 equal nodes (same configuration, same capacity).

Thanks.

edit retag flag offensive close merge delete

Comments

What are your current availability zones in Cinder? Try both of these, see if they match, it's possible that one backend is in a different AZ so it's stacking on the first AZ that's associated with Nova (where the instances are launching):

nova availability-zone-list

cinder availability-zone-list

mpetason gravatar imagempetason ( 2014-07-29 11:02:40 -0500 )edit

I have only one availability zone "nova" which is specifically set as default zone in cinder configuration: default_availability_zone = nova

zeljko-jagust gravatar imagezeljko-jagust ( 2014-07-30 02:51:39 -0500 )edit