devstack local.conf backslash

asked 2014-07-26 12:37:23 -0500

lofifnc gravatar image

We have a username for our vshere server containing a backslash "\". When defining it in the local.conf the username is inserted into the nova.conf without a backslash. Escaping it with another backslash "\" didn't work as well.

lofifnc

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
1

answered 2014-08-04 11:29:11 -0500

Had similar issue and solved like this:

$ export USER=/abcd/xyz/

$ export ESCAPED_USER='echo $USER | sed 's/\//\\\\\//g'`

Then you can pass the $ESCAPED_USER to your program/file. You may need to make the appropriate slash(forward or backward) in your case. Hope this helps.

edit flag offensive delete link more

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-07-26 12:37:23 -0500

Seen: 157 times

Last updated: Aug 04 '14