Ask Your Question
1

ZeroMQ configuration assistance [closed]

asked 2014-07-25 09:22:15 -0500

Nuriel gravatar image

Hi,

I am interested in trying out ZeroMQ on two nodes (controller + compute node/hypervisor). Currently the nova.conf on the controller consists of the following definitions:

rpc_zmq_bind_address=* 
rpc_zmq_matchmaker=oslo.messaging._drivers.matchmaker_ring.MatchMakerRing 
rpc_zmq_port=9501 
rpc_zmq_contexts=1 
rpc_zmq_ipc_dir=/var/run/openstack 
rpc_zmq_host=openstack5
rpc_backend=zmq

The directory '/var/run/openstack' created and owned by user nova. Installed ZeroMQ packages. Created the json file '/etc/oslo/matchmaker_ring.json' containing:

  {
    "conductor":["openstack5"],
    "compute":["openstack5"],
    "network":["openstack5"],
    "consoleauth":["openstack5"],
    "scheduler":["openstack5"]
  }

Not sure about the following, but I have manually started 'oslo-messaging-zmq-receiver --config-file /etc/nova/nova.conf' Output as follows:

DEBUG:oslo.messaging._drivers.impl_zmq:Connecting to tcp://*:9501 with PULL
DEBUG:oslo.messaging._drivers.impl_zmq:-> Subscribed to None
DEBUG:oslo.messaging._drivers.impl_zmq:-> bind: True
INFO:oslo.messaging._drivers.impl_zmq:In reactor registered
INFO:oslo.messaging._drivers.impl_zmq:Consuming socket
INFO:oslo.messaging._drivers.impl_zmq:Creating proxy for topic: conductor.master
DEBUG:oslo.messaging._drivers.impl_zmq:Connecting to ipc:///var/run/openstack/zmq_topic_conductor.master with PUSH
DEBUG:oslo.messaging._drivers.impl_zmq:-> Subscribed to None
DEBUG:oslo.messaging._drivers.impl_zmq:-> bind: True

Openstack logs:

Jul 25 16:05:31 openstack5 OpenStack[      nova:29123]    INFO: Registering reactor [-]
Jul 25 16:05:31 openstack5 OpenStack[      nova:29123]    INFO: In reactor registered [-]
Jul 25 16:05:31 openstack5 OpenStack[      nova:29123]    INFO: Skipping topic registration. Already registered. [-]
Jul 25 16:05:31 openstack5 OpenStack[      nova:29123]    INFO: Registering reactor [-]
Jul 25 16:05:31 openstack5 OpenStack[      nova:29123]    INFO: In reactor registered [-]
Jul 25 16:05:31 openstack5 OpenStack[      nova:29123]    INFO: Consuming socket [-]
Jul 25 16:05:31 openstack5 OpenStack[      nova:29123]    INFO: Consuming socket [-]

So far it looks to me as if the configuration on the contoller is okay (not sure about that though). Now the problem is that I did the same configuration steps for the compute node but I keep getting:

Jul 25 16:05:15 node001 OpenStack[ nova: 5933]CRITICAL: Timeout: Timeout while waiting on RPC response - topic: "<unknown>", RPC method: "<unknown>" info: "<unknown>"#012 [req-0ac7ad20-b0bb-4802-b8fc-2b4e30795077 None None] ....

If somebody could point out how the compute node should be configured, an example of controller + compute node with zeromq configuration would be very much appreciated.

Thanks in advance.

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Nuriel
close date 2014-07-28 06:00:17.322207

1 answer

Sort by ยป oldest newest most voted
0

answered 2014-07-25 10:08:34 -0500

Nuriel gravatar image

update: Forgot to mention: using IceHouse.

Started up the command 'oslo-messaging-zmq-receiver --config-file /etc/nova/nova.conf' as user 'nova' seems to have taken me a step forward. Two sockets created on the compute-node:

srwxr-xr-x 1 nova nova 0 Jul 25 16:58 zmq_topic_conductor.node001
srwxr-xr-x 1 nova nova 0 Jul 25 16:58 zmq_topic_zmq_replies.node001

One socket on the controller:

srwxr-xr-x 1 nova nova 0 Jul 25 16:58 zmq_topic_conductor.openstack5

However now facing the log error:

Jul 25 16:59:49 node001 OpenStack[      nova: 9214]   DEBUG: The version of python-libvirt does not support registerCloseCallback or is too old: registerCloseCallback() takes exactly 4 arguments (3 given) [-] _get_new_connection /usr/lib/python2.6/site-packages/nova/virt/libvirt/driver.py:707
Jul 25 16:59:49 node001 OpenStack[      nova: 9214]   ERROR: internal error client socket is closed [-]#0122014-07-25 16:59:49.116 9214 TRACE nova.openstack.common.threadgroup Traceback (most recent call last):#0122014-07-25 16:59:49.116 9214 TRACE nova.openstack.common.threadgroup...
edit flag offensive delete link more

Comments

Managed to get this working by setting the correct values in the "/etc/oslo/matchmaker_ring.json" file, the entry for compute had to be "node001" which happens to be the only compute node I am currently using.

Nuriel gravatar imageNuriel ( 2014-07-28 05:59:41 -0500 )edit

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-07-25 09:22:15 -0500

Seen: 251 times

Last updated: Jul 25 '14