Ask Your Question
0

VM cannot access external network

asked 2014-07-25 05:00:42 -0500

qmo gravatar image

updated 2014-07-25 08:14:50 -0500

Hi,

I've just installed openstack on 3 nodes and everything exept internet access for vm is working fine.

I have 2 controllers : the first one is the main controller with nova, glance, cinder the second one is the network controller and is configured with neutron

The problem is that all my VMs cannot reach the outside network. they can ping eachother routing within the openstack network is working fine.

The installation use OVS.

The networking node fot 3 cards: one for the instance tunnels one for the management one for the external network

the external interface is configured with no ip es axplained in the documentations. all the infrastructure is virtualized in xenserver. I can't see any error in the neutron logs.

Thanks, qmo.

EDIT

Controller :

 [root@controller001 ~]# ifconfig
    eth0      Link encap:Ethernet  HWaddr 5A:06:E0:24:49:38
              inet addr:10.10.193.10  Bcast:10.10.193.255  Mask:255.255.255.0
              inet6 addr: fe80::5806:e0ff:fe24:4938/64 Scope:Link
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:3149168 errors:0 dropped:0 overruns:0 frame:0
              TX packets:1208568 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000
              RX bytes:487459777 (464.8 MiB)  TX bytes:328022134 (312.8 MiB)
              Interrupt:23

    eth1      Link encap:Ethernet  HWaddr 3E:68:84:53:5A:C0
              inet addr:172.16.193.1  Bcast:172.16.193.255  Mask:255.255.255.0
              inet6 addr: fe80::3c68:84ff:fe53:5ac0/64 Scope:Link
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:1841189 errors:0 dropped:0 overruns:0 frame:0
              TX packets:15 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000
              RX bytes:154131593 (146.9 MiB)  TX bytes:1014 (1014.0 b)
              Interrupt:22

    lo        Link encap:Local Loopback
              inet addr:127.0.0.1  Mask:255.0.0.0
              inet6 addr: ::1/128 Scope:Host
              UP LOOPBACK RUNNING  MTU:16436  Metric:1
              RX packets:4670831 errors:0 dropped:0 overruns:0 frame:0
              TX packets:4670831 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:0
              RX bytes:1454679886 (1.3 GiB)  TX bytes:1454679886 (1.3 GiB)

The main controller doesn't use OVS

Neutron controller :

[root@network001 ~]# ifconfig
br-ex     Link encap:Ethernet  HWaddr 5A:5A:3F:16:52:48
          inet6 addr: fe80::705f:83ff:fe7a:cbfb/64 Scope:Link
          UP BROADCAST RUNNING  MTU:1500  Metric:1
          RX packets:3817 errors:0 dropped:0 overruns:0 frame:0
          TX packets:6 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:301298 (294.2 KiB)  TX bytes:468 (468.0 b)

br-int    Link encap:Ethernet  HWaddr 5E:A3:F8:79:6F:41
          inet6 addr: fe80::a485:bdff:fe3c:fbce/64 Scope:Link
          UP BROADCAST RUNNING  MTU:1500  Metric:1
          RX packets:58 errors:0 dropped:0 overruns:0 frame:0
          TX packets:6 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 ...
(more)
edit retag flag offensive close merge delete

Comments

Please post ovs-vsctl show and ifconfig on NeutronServer && Controller.

dbaxps gravatar imagedbaxps ( 2014-07-25 06:55:22 -0500 )edit

On NeuttronServer eth0 should be OVS port of OVS bridge br-ex . eth0's IP should be assigned br-ex, eth0 is not supposed to have IP address at all.
Please post the neutron command to create external network.

dbaxps gravatar imagedbaxps ( 2014-07-25 07:45:04 -0500 )edit
1

Is 192.168.168.1 real gateway IP address on real internet enabled network 192.168.168.0/24 ?
If above is correct and currently eth2 is OVS port at br-ex , then assign br-ex IP from network 192.168.168.0/24.

dbaxps gravatar imagedbaxps ( 2014-07-25 08:43:51 -0500 )edit

Thanks a lot, everything is working fine now ! with the ip on the br-ex interface.

qmo gravatar imageqmo ( 2014-07-28 01:27:06 -0500 )edit

2 answers

Sort by ยป oldest newest most voted
1

answered 2014-07-28 04:07:14 -0500

dbaxps gravatar image
Is 192.168.168.1 real gateway IP address on real internet enabled network 192.168.168.0/24 ?
If above is correct and currently eth2 is OVS port at br-ex , then assign br-ex IP from network 192.168.168.0/24.
edit flag offensive delete link more
0

answered 2014-07-28 05:40:26 -0500

totten25 gravatar image

updated 2014-07-28 05:42:26 -0500

From dbaxps' s suggestion, OpenStack Documentation didn't tell about setting up br-ex. i suppose that you create br-ex as a name of bridge interface of eth0 as external interface to connecting the outside world.

auto br-ex
iface br-ex inet static
        address 10.10.193.10
        netmask 255.255.255.0
        gateway 10.10.193.1
        dns-nameservers  8.8.8.8

auto eth0
iface eth0 inet manual
up ip address add 0/0 dev $IFACE
up ip link set $IFACE up
down ip link set $IFACE down

after you've configure like above, just remove ip address of eth0 and just add ip address of br-ex and restart network

ip addr del 10.10.193.10/24 dev eth0 
ip addr add 10.10.193.10/24 dev br-ex
/etc/init.d/networking restart # for Ubuntu 12.04 
service networking restart # for Ubuntu 14.04

after you've done this and if you found some problem, please check routing table and tcpdump of virtual router. Anyway, i ever faced problem about creating external network, my vm cannot access internet. When I check routing table of virtual router, i found that my default gateway is not my ip address gateway of my lab environment.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-07-25 05:00:42 -0500

Seen: 1,181 times

Last updated: Jul 28 '14