Ask Your Question
0

How to use VLAN and GRE together with ML2? [closed]

asked 2014-07-24 15:43:39 -0500

jproulx gravatar image

updated 2014-07-24 15:44:35 -0500

Under Havana with Neutron OVS I'm using provider vlan networks and GRE based tenant tetworks.

After upgrading a test environment from Havana to Icehouse and moving from OVS to ML2+OVS, the VLAN based networks are running properly but the GRE tunnels are not being created.

ml2_conf.ini (on both networ and compute nodes) is

[ovs]
network_vlan_ranges=trunk:2112:2114
local_ip=10.10.10.20
enable_tunneling=True
integration_bridge=br-int
tunnel_id_ranges=1:1000
tunnel_bridge=br-tun
bridge_mappings=trunk:eth1-br
tunnel_type=gre
[agent]
tunnel_types=gre
l2_population=true
polling_interval=30
veth_mtu=9134
[securitygroup]
enable_security_group=true
firewall_driver=neutron.agent.linux.iptables_firewall.OVSHybridIptablesFirewallDriver
[ml2]
type_drivers=vlan,gre
tenant_network_types=gre
mechanism_drivers = openvswitch
[ml2_type_flat]
[ml2_type_vlan]
network_vlan_ranges=trunk:2112:2114
[ml2_type_gre]
tunnel_id_ranges=1:1000
[ml2_type_vxlan]

Debug logs from startup pasted at http://pastebin.com/8YnNnaAd these are from the compute node side though the network serve has similar issues. The 'br-tun' device exists as does the patch-int/patch-tun veth pair but there are no gre-XX devices.

More configs, note that VLAN provider networks are working, just GRE is broken :

I can see rpc calls in the logs related to gre tunnels, but there is never any call to actually creat the tunnel. for example on Havana I see the rpc then a rootwrap call to creat the tunnel device:

2014-07-24 11:56:05.490 26986 DEBUG neutron.openstack.common.rpc.amqp [-] received {u'_context_roles': [u'admin'], u'_context_read_deleted': u'no', u'_context_tenant_id': None, u'args': {u'tunnel_ip': u'10.10.10.49', u'tunnel_type': u'gre', u'tunnel_id': 32}, u'namespace': None, u'_unique_id': u'1460d7a33fb948f2aca88fe59b3a59e2', u'_context_is_admin': True, u'version': u'1.0', u'_context_project_id': None, u'_context_timestamp': u'2014-07-10 17:28:57.890006', u'_context_user_id': None, u'method': u'tunnel_update'} _safe_log /usr/lib/python2.7/dist-packages/neutron/openstack/common/rpc/common.py:276
2014-07-24 11:56:05.492 26986 DEBUG neutron.agent.linux.utils [-] Running command: ['sudo', 'neutron-rootwrap', '/etc/neutron/rootwrap.conf', 'ovs-vsctl', '--timeout=2', '--', '--may-exist', 'add-port', 'br-tun', 'gre-32'] execute /usr/lib/python2.7/dist-packages/neutron/agent/linux/utils.py:43
Command: ['sudo', 'neutron-rootwrap', '/etc/neutron/rootwrap.conf', 'ovs-vsctl', '--timeout=2', '--', '--may-exist', 'add-port', 'br-tun', 'gre-32']

But in Icehouse all I get is the rpc with no following rootwrap call:

2014-07-24 11:53:20.286 31673 DEBUG neutron.openstack.common.rpc.amqp [-] received {u'_context_roles': [u'admin'], u'_context_request_id': u'req-3eede0e4-0d75-4fe4-bda0-fa945848462f', u'_context_read_deleted': u'no', u'_context_user_name': None, u'_context_project_name': None, u'namespace': None, u'_context_tenant_id': None, u'args': {u'tunnel_ip': u'128.52.128.20', u'tunnel_type': u'gre'}, u'_context_tenant': None, u'_unique_id': u'441cd7adb999433dbcd50038e2632312', u'_context_is_admin': True, u'version': u'1.1', u'_context_timestamp': u'2014-07-24 15:53:17.405253', u'_context_tenant_name': None, u'_context_user': None, u'_context_user_id': None, u'method': u'tunnel_update', u'_context_project_id': None} _safe_log /usr/lib/python2.7/dist-packages/neutron/openstack/common/rpc/common.py:280
edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by jproulx
close date 2014-07-24 20:34:02.299891

1 answer

Sort by ยป oldest newest most voted
0

answered 2014-07-24 20:33:36 -0500

jproulx gravatar image

issue here is misconfiguration fo the l2_population.

removing AGENT/l2_population=true configuration gets tunnels created.

how to properly configure l2_population is a different question...

edit flag offensive delete link more

Comments

for l2 pop, you need to add the l2 pop mechanism driver to the mechanism_drivers list on the plugin

darragh-oreilly gravatar imagedarragh-oreilly ( 2014-07-25 01:45:31 -0500 )edit

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-07-24 15:43:39 -0500

Seen: 846 times

Last updated: Jul 24 '14