Ask Your Question
0

ovs errors: ovs-system shows, br-ex doesn

asked 2014-07-24 07:39:02 -0600

don gravatar image

My 'br-ex' interface is up (according to ifconfig) but UNKNOWN according to 'ip link' and 'cat /sys/class/net/br-ex/operstatus'. Is this to be expected? E.g., below, creating from scratch. The same is true of br-int and br-tun.

# ifconfig br-ex
br-ex     Link encap:Ethernet  HWaddr 00:1b:21:65:b2:84  
          inet addr:10.129.247.8  Bcast:10.129.247.255  Mask:255.255.255.0
          inet6 addr: fe80::308f:1eff:fe92:a9fc/64 Scope:Link
          UP BROADCAST RUNNING  MTU:1500  Metric:1
          RX packets:1 errors:0 dropped:1 overruns:0 frame:0
          TX packets:8 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:279 (279.0 B)  TX bytes:648 (648.0 B)


# ovs-vsctl show
1603bde4-cd87-4e9b-a169-95447bc8bbca
    ovs_version: "2.0.1"
root@nubo-7:~# ovs-vsctl add-br br-ex
root@nubo-7:~# ovs-vsctl add-port br-ex p3p1
root@nubo-7:~# ovs-vsctl show
1603bde4-cd87-4e9b-a169-95447bc8bbca
    Bridge br-ex
        Port br-ex
            Interface br-ex
                type: internal
        Port "p3p1"
            Interface "p3p1"
    ovs_version: "2.0.1"
root@nubo-7:~# ovs-dpctl show
system@ovs-system:
        lookups: hit:102 missed:53 lost:0
        flows: 0
        port 0: ovs-system (internal)
        port 1: br-ex (internal)
        port 2: p3p1
root@nubo-7:~# ovs-dpctl show ovs-system
system@ovs-system:
        lookups: hit:102 missed:54 lost:0
        flows: 1
        port 0: ovs-system (internal)
        port 1: br-ex (internal)
        port 2: p3p1
root@nubo-7:~# ovs-dpctl show br-ex
ovs-dpctl: opening datapath br-ex failed (No such device)
root@nubo-7:~# ovs-ofctl show br-ex
OFPT_FEATURES_REPLY (xid=0x2): dpid:0000001b2165b284
n_tables:254, n_buffers:256
capabilities: FLOW_STATS TABLE_STATS PORT_STATS QUEUE_STATS ARP_MATCH_IP
actions: OUTPUT SET_VLAN_VID SET_VLAN_PCP STRIP_VLAN SET_DL_SRC SET_DL_DST SET_NW_SRC SET_NW_DST SET_NW_TOS SET_TP_SRC SET_TP_DST ENQUEUE
 1(p3p1): addr:00:1b:21:65:b2:84
     config:     0
     state:      0
     current:    1GB-FD AUTO_NEG
     advertised: 1GB-FD 10GB-FD FIBER AUTO_NEG
     supported:  1GB-FD 10GB-FD FIBER AUTO_NEG
     speed: 1000 Mbps now, 10000 Mbps max
 LOCAL(br-ex): addr:00:1b:21:65:b2:84
     config:     0
     state:      0
     speed: 0 Mbps now, 0 Mbps max
OFPT_GET_CONFIG_REPLY (xid=0x4): frags=normal miss_send_len=0
root@nubo-7:~# ip link 
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN mode DEFAULT group default 
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: em1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP mode DEFAULT group default qlen 1000
    link/ether 00:26:b9:fb:fd:fc brd ff:ff:ff:ff:ff:ff
3: em2: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN mode DEFAULT group default qlen 1000
    link/ether 00:26:b9:fb:fd:fe brd ff:ff:ff:ff:ff:ff
4: p1p1: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN mode DEFAULT group default qlen 1000
    link/ether 00:10:18:6e:dd:54 brd ff:ff:ff:ff:ff:ff
5: p1p2: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN mode DEFAULT group default qlen 1000
    link/ether 00:10:18:6e:dd:56 brd ff:ff:ff:ff:ff:ff
6: p3p1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq master ovs-system state UP mode DEFAULT group default ...
(more)
edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2016-02-29 15:00:01 -0600

Thiyagu gravatar image

Hi , Did you get to fix this issue ??? , Even i'm facing the same problem...

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-07-24 07:39:02 -0600

Seen: 3,003 times

Last updated: Feb 29 '16