Ask Your Question
1

Error accessing Dashboard: "RuntimeError Unable to create a new session key"

asked 2014-07-23 06:56:37 -0500

fhussain gravatar image

updated 2014-07-23 06:57:03 -0500

Hi,

I am trying to access Dashboard via web browser using the url http://controller/horizon . The login is successful, but after that a page is displayed " Something went wrong! An unexpected error has occurred. Try refreshing the page".

I have checked the error log in /var/log/apache2/error.log and the error is this:

RuntimeError: Unable to create a new session key. It is likely that the cache is unavailable.

Please help me solve the issue.

Thanks.

edit retag flag offensive close merge delete

6 answers

Sort by » oldest newest most voted
1

answered 2016-12-26 05:49:21 -0500

sanjay gravatar image

Thanks It worked after #SESSION_ENGINE = 'django.contrib.sessions.backends.cache'

edit flag offensive delete link more
0

answered 2016-04-07 23:19:15 -0500

IceX gravatar image

I had the same problem....

SESSION_ENGINE = 'django.contrib.sessions.backends.cache'

CACHES = { 'default': { 'BACKEND': 'django.core.cache.backends.memcached.MemcachedCache', 'LOCATION': 'controller1:11211', } } If I use the fqdn (e.g controller1) in the location it fails, try changing it to the IP (e.g. 10.0.0.11 or 127.0.0.1).

SESSION_ENGINE = 'django.contrib.sessions.backends.cache'

CACHES = { 'default': { 'BACKEND': 'django.core.cache.backends.memcached.MemcachedCache', 'LOCATION': '10.0.0.11:11211', } }

edit flag offensive delete link more

Comments

Did you solve this problem ? ı had same problem too.

gokhan.isik gravatar imagegokhan.isik ( 2016-05-30 05:45:36 -0500 )edit
0

answered 2016-09-26 06:25:23 -0500

Dhamodran P gravatar image

I too faced the same problem ,

Comment out the line SESSION_ENGINE from /etc/openstack-dashboard/local_settings file.

This fixed my issue

edit flag offensive delete link more

Comments

This also fixed my problem. Checked django document. It seemed that this is openstack doc error.

Jared gravatar imageJared ( 2017-02-13 21:40:29 -0500 )edit
0

answered 2016-06-08 06:35:37 -0500

MrDan gravatar image

Yes, this worked.

edit flag offensive delete link more
0

answered 2017-07-23 14:29:23 -0500

Pranay Sagar gravatar image

I figured out my problem: The problem is I did not see the note after you edit /etc/sysconfig/memcached file. I had to change this line -l 127.0.0.1 to this line -l MangementcontrollerIP (for Example-10.0.0.11). The IP that you set in mentioned file
/etc/openstack-dashboard/local_settings CACHES = { 'default': { 'BACKEND': 'django.core.cache.backends.memcached.MemcachedCache', 'LOCATION': '10.0.0.11:11211', } } After the just run this command : systemctl restart memcached.service

Hope it will work for you ... if not Kindly paste you error.log file will trying to help you out ...

edit flag offensive delete link more
0

answered 2016-06-17 15:31:36 -0500

dchowdhu gravatar image

Yes, it did work. I had same problem and changing memcached location did work for me. However, I am sseeing "unexpected error" when browsing Network=>topology sections within horizon dashboard. Perhaps I need to configure network topology in the neurton.conf. Any suggestion.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

2 followers

Stats

Asked: 2014-07-23 06:56:37 -0500

Seen: 4,494 times

Last updated: Jul 23 '17