Ask Your Question
0

no default gateway on neutron router

asked 2014-07-23 04:16:28 -0500

zilahia gravatar image

updated 2014-07-23 07:13:49 -0500

Hi!

I'm installing OpenStack IceHouse with Neutron on F20 Fedora by following the guide. I'm using the three node architecture(Controller, Network, Compute) and I have a connectivity problem: The instances cannot reach the Internet.
The private network is 192.168.1.0/24, the public is 172.16.0.0./24. I can ping every host on the two network, but nothing outside this. I've found out that setting the default gateway in the network namespace(netns) of the router fixes the problem(on the network node):

[root@network ~]#  ip netns exec qrouter-152a7eaa-9d46-4b93-8fcd-c07bcc7017d2 ip route add default via 172.16.0.1

Because of this easy solution, i think this should be a network configuration problem, even though I've followed the guide while setting up the network. This is my configuration:

http://pastebin.com/qHMZQxAp

This is the neutron config: http://pastebin.com/YCCh7d6R

ovs-vsctl show: http://pastebin.com/enWWnhnR

Can you help me with this?

edit retag flag offensive close merge delete

Comments

you are right, the neutron router should have default gw set to 172.16.0.1

which is the command ovs-vsctl show output? could you pastebin your neutron config files (neutron and ovs)?

Antonio G. gravatar imageAntonio G. ( 2014-07-23 06:00:11 -0500 )edit

Thank you for your comment, I have updated the missing information to the original post.

zilahia gravatar imagezilahia ( 2014-07-23 07:18:05 -0500 )edit

it seems correct, do you have any error in neutron related log files? did you follow the guide for external network creation commands?

Antonio G. gravatar imageAntonio G. ( 2014-07-23 07:44:07 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
2

answered 2014-07-24 04:11:00 -0500

zilahia gravatar image

updated 2014-07-24 04:12:06 -0500

Hi Antonio and Others!

After your question about the logs, i reviewed them, and the problem was there. If the debug was on false, there were no errors at all. After I had turned it on, there were too many logs to find anything useful with bare eyes, so i started to grep suspicious words. The grep "Stderr:" helped me. There was a"Command not found" error somewhere in the huge log file. It turned out that Neutron needs the route command from the net-tools package. I used the "ip route" and didn't think of any other routing table modifying command. Neutron tricked me with this:

  • It uses "ip netns", then why use "route" and depend on net-tools instead of just using "ip route"
  • There was a low level error, but it went silent, making it hard to debug.

Gladly i fixed it in no time :) Thank you for your time and patience.

edit flag offensive delete link more

Comments

Thank you ! You have answered the question that bugging me for a week!

t.goto gravatar imaget.goto ( 2014-10-27 23:07:06 -0500 )edit

Hi, I have Icehouse setup on Centos 6.6. I am facing the same problem but in my case , default gateway for router is set as IP of network node. Still the instances are not able to ping nodes and internet. Also nodes are not able to ping VMs directly without namespace. Please suggest some solution.

smcas gravatar imagesmcas ( 2015-10-29 01:38:24 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-07-23 04:16:28 -0500

Seen: 2,335 times

Last updated: Jul 24 '14