Ask Your Question
0

quantum-server status is dead

asked 2013-08-21 11:15:57 -0500

krzysiekg91 gravatar image

updated 2013-08-21 17:51:32 -0500

smaffulli gravatar image

Hello,

I am trying to deploy openstack on three nodes - (1) controller node, (2) compute node and (3) network node.

I am working on CentOS and following this tutorial https://access.redhat.com/site/documentation/en-US/Red_Hat_OpenStack/3/pdf/Installation_and_Configuration_Guide/Red_Hat_OpenStack-3-Installation_and_Configuration_Guide-en-US.pdf

Now I am configuring Network Node. Network configuration starts at page 92. Firstly I would like to run quantum-server so I did everything from page 92 to 105. But something is not working.

When I do " service quantum-server restart" the result is

Stopping quantum: [FAILED]

Starting quantum: [ OK ]

And it happens all the time, that means that quantum-server works only a short period of time and it comes dead.

When I do

quantum-server --config-file /etc/quantum/quantum.conf --debug --verbose

the logs are as follows

INFO [quantum.service] Quantum service started, listening on 0.0.0.0:9696

2013-08-21 17:50:14 DEBUG [qpid.messaging.io.raw] SENT[2775e60]: '\x0f\x01\x00\x19\x00\x01\x00\x00\x00\x00\x00\x00\x04\n\x01\x00\x07\x00\x010\x01\xff\xff\xff\xff\x0f\x01\x00\ x19\x00\x01\x00\x00\x00\x00\x00\x00\x04\n\x01\x00\x07\x00\x010\x00\x00\x00\x00\x01'

2013-08-21 17:51:13 DEBUG [qpid.messaging.io.ops] SENT[2775e60]: ConnectionHeartbeat()

2013-08-21 17:51:13 DEBUG [qpid.messaging.io.raw] SENT[2775e60]: '\x0f\x00\x00\x10\x00\x00\x00\x00\x00\x00\x00\x00\x01\n\x00\x00'

2013-08-21 17:51:13 DEBUG [qpid.messaging.io.raw] READ[2775e60]: '\x0f\x00\x00\x10\x00\x00\x00\x00\x00\x00\x00\x00\x01\n\x00\x00'

2013-08-21 17:51:13 DEBUG [qpid.messaging.io.ops] RCVD[2775e60]: ConnectionHeartbeat()

2013-08-21 17:52:13 DEBUG [qpid.messaging.io.ops] SENT[2775e60]: ConnectionHeartbeat()

2013-08-21 17:52:13 DEBUG [qpid.messaging.io.raw] SENT[2775e60]: '\x0f\x00\x00\x10\x00\x00\x00\x00\x00\x00\x00\x00\x01\n\x00\x00'

2013-08-21 17:52:13 DEBUG [qpid.messaging.io.raw] READ[2775e60]: '\x0f\x00\x00\x10\x00\x00\x00\x00\x00\x00\x00\x00\x01\n\x00\x00'

2013-08-21 17:52:13 DEBUG [qpid.messaging.io.ops] RCVD[2775e60]: ConnectionHeartbeat()

**that means that something is working. Also MySQL database on controller node sees that user quantum is logged. But the command

openstack-status ends with**

== Quantum services ==

quantum-server: dead

quantum-dhcp-agent: inactive (disabled on boot)

quantum-l3-agent: inactive (disabled on boot)

quantum-linuxbridge-agent: dead (disabled on boot)

quantum-openvswitch-agent: inactive (disabled on boot)

openvswitch: active (disabled on boot)

Here are my config files

api-paste.ini

[composite:quantum] use = egg:Paste#urlmap /: quantumversions /v2.0: quantumapi_v2_0

[composite:quantumapi_v2_0] use = call:quantum.auth:pipeline_factory noauth = extensions quantumapiapp_v2_0 keystone = authtoken keystonecontext extensions quantumapiapp_v2_0

[filter:keystonecontext] paste.filter_factory = quantum.auth:QuantumKeystoneContext.factory

[filter:authtoken] paste.filter_factory = keystoneclient.middleware.auth_token:filter_factory auth_host = 192.168.0.1 auth_port = 35357 auth_protocol = http admin_tenant_name = service admin_user = quantum admin_password = openstack

[filter:extensions] paste.filter_factory = quantum.api.extensions:plugin_aware_extension_middleware_factory

[app:quantumversions] paste.app_factory = quantum.api.versions:Versions.factory

[app:quantumapiapp_v2_0] paste.app_factory = quantum.api.v2.router:APIRouter.factory

quantum.conf ... (more)

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2013-08-23 15:36:26 -0500

foexle gravatar image

I had a similar problem with quantum on ubuntu and RabbitMQ. There was the problem that RabbitMQ was not working correctly and peaces of my cloud was going to a strange behavior. The strange thing was, no error in RabbitMQ or Neutron (Quantum) but a restart of them resolved the problem.

Maybe you should check your AMQP server.

Cheers

edit flag offensive delete link more

Comments

Thanks you for your response. Can I have your Skype or Facebook nick, because I have few questions about Openstack? Thank you.

krzysiekg91 gravatar imagekrzysiekg91 ( 2013-09-05 08:41:59 -0500 )edit

nick in irc is foexle :)

foexle gravatar imagefoexle ( 2013-09-19 09:00:44 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2013-08-21 11:15:57 -0500

Seen: 536 times

Last updated: Sep 05 '13