Ask Your Question
3

ERROR [cinder.openstack.common.rpc.common] AMQP server on localhost:5672 is unreachable: Socket closed.

asked 2013-08-21 07:36:19 -0500

eecszhu gravatar image

updated 2013-08-21 09:09:30 -0500

Jobin gravatar image

I am trying to deply all Grizzly components on 1 machine with Ubuntu 12.04.2 LTS. After Cinder installation, I tried:

cinder create --display_name test 1

And got above error message.

I checked RabbitMQ user Id and password , both are correct and rabbitmq-server is up-running.

cinder.conf is as below:

[DEFAULT]

rootwrap_config = /etc/cinder/rootwrap.conf

sql_connection = mysql://cinder:cloud@localhost/cinder

api_paste_config = /etc/cinder/api-paste.ini

iscsi_helper = tgtadm

volume_name_template = volume-%s

volume_group = cinder-volumes

verbose = True

auth_strategy = keystone

\#osapi_volume_listen_port=5900

rabbit_host = localhost

rabbit_port = 5672

rabbit_userid = guest

rabbit_password = cloud

rabbit_virtual_host = /nova

rabbit_hosts=$rabbit_host:$rabbit_port

rabbit_use_ssl=false

state_path = /var/lib/cinder

lock_path = /var/lock/cinder

volumes_dir = /var/lib/cinder/volumes

Am i wrong? All i did is follow the installation guide ...

Thanks a lot!

edit retag flag offensive close merge delete

Comments

1

Can you check if port 5672 is open using `netstat -ntlp | grep 5672`?

Jobin gravatar imageJobin ( 2013-08-21 09:49:31 -0500 )edit

Yes, it is opened: tcp6 0 0 :::5672 :::* LISTEN 1320/beam.smp

eecszhu gravatar imageeecszhu ( 2013-08-21 09:56:14 -0500 )edit

@Jobin, this is my out put for that command, and I'm facing the same problem, seems my rabbit can't bind to port 5672 in IPv4:

tcp        0      0 0.0.0.0:25672           0.0.0.0:*               LISTEN      3856/beam.smp
tcp6       0      0 :::5672                 :::*                    LI
darren-wang gravatar imagedarren-wang ( 2015-04-05 04:17:19 -0500 )edit

3 answers

Sort by ยป oldest newest most voted
4

answered 2013-08-21 14:07:49 -0500

nosluoc gravatar image

updated 2013-08-21 14:08:29 -0500

I ran into this problem when installing/configuring DevStack where just like you, the port was open, I verified the RabbitMQ service was running, AND checked my credentials. I stumbled upon this page, which had me change the RabbitMQ guest user password, and restart the RabbitMQ service, which remedied my problem. Not entirely sure why this would have happened, but it might help you.

Change the RabbitMQ guest password: sudo rabbitmqctl change_password guest password

Restart RabbitMQ service: sudo service rabbitmq restart

edit flag offensive delete link more

Comments

i tried this approach ... but it does not work for me...

eecszhu gravatar imageeecszhu ( 2013-08-21 19:18:37 -0500 )edit

Changing the password into "guest" instead of "password" worked for me (after analyzing the config-file "/etc/neutron/neutron.conf", looking for "rabbit"). So not "guest password" as in above's answer, but "guest guest".

Henk gravatar imageHenk ( 2013-12-15 10:05:21 -0500 )edit

Didn't work for me too. .... I am still getting this error.

waqasriaz gravatar imagewaqasriaz ( 2014-01-11 13:17:57 -0500 )edit

Be aware the the RabbitMQ settings so if you changed the hostname/ip of the server running the RabbitMQ the password of the guest user will be reset. And you need to do this again.

ecerulm gravatar imageecerulm ( 2014-04-17 05:42:17 -0500 )edit

Just changing the password to guest (not password) worked for me - instantly with no service restart. It does not match my .conf settings for rabbit_password:

sudo rabbitmqctl change_password guest guest
jame gravatar imagejame ( 2014-06-09 09:46:45 -0500 )edit
0

answered 2014-02-06 00:55:23 -0500

dodgerfan78 gravatar image

My problem was I had the rabbit_password commented out in the quantum.conf file

Once I removed the # all the errors I was getting in Horizon went away.

edit flag offensive delete link more

Comments

it seems doesn't work.

Dongcan Ye gravatar imageDongcan Ye ( 2014-07-29 04:43:40 -0500 )edit
0

answered 2015-01-06 01:57:40 -0500

arbcat gravatar image

Make sure to check if "telnet localhost 5672" is actually available. I could telnet to the vhost0 IP but not 127.0.0.1. As a quick dirty hack, you can modify /etc/cinder/cinder.conf 's "rabbit_host=" to be that of vhost0

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

Stats

Asked: 2013-08-21 07:36:19 -0500

Seen: 11,109 times

Last updated: Feb 06 '14