Neutron L3 agent gives error while adding to pacemaker [closed]

asked 2014-07-18 13:14:49 -0600

rahulrajvn gravatar image

updated 2014-07-19 13:08:24 -0600

I am trying to configure HA for neutron server in icehouse implementation. I was able to set up ha for all other services except neutron. Current I am trying to use pacemaker for setting up HA . I am trying to follow doc.

but still i get following error. dhcp agent and metadata agent is showing no error but l3 agent is not working.

If any body have any suggestions which I can try please update.

output of crm_mon -1

Last updated: Fri Jul 18 14:03:25 2014
Last change: Fri Jul 18 13:54:04 2014 via cibadmin on network1
Stack: classic openais (with plugin)
Current DC: network2 - partition with quorum
Version: 1.1.10-14.el6_5.3-368c726
2 Nodes configured, 2 expected votes
4 Resources configured
 Online: [ network1 network2 ]
 p_api-ip       (ocf::heartbeat:IPaddr2):       Started network2
 p_neutron-dhcp-agent   (ocf::openstack:neutron-dhcp-agent):    Started network1
 p_neutron-metadata-agent       (ocf::openstack:neutron-metadata-agent):        Started network1
Failed actions:
    p_neutron-l3-agent_start_0 on network2 'unknown error' (1): call=13, status=Timed Out, last-rc-change='Fri Jul 18 04:32:06 2014', queued=20091ms, exec=0ms
    p_neutron-l3-agent_start_0 on network1 'unknown error' (1): call=23, status=Timed Out, last-rc-change='Fri Jul 18 14:03:01 2014', queued=20010ms, exec=0ms
[root@network1 openstack]#
edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by rahulrajvn
close date 2014-07-21 10:58:20.048949

Comments

please read faq before posting question and also update heading & content.

SGPJ gravatar imageSGPJ ( 2014-07-18 13:47:36 -0600 )edit

Check if this answers your question https://ask.openstack.org/en/question... If not, edit your question and add more details as you investigate further

smaffulli gravatar imagesmaffulli ( 2014-07-19 11:56:59 -0600 )edit

Hi , My current setup is having two controller node, two network node and more than two compute node . Neutron server is running in Controller node and Network node runs L3 agent, metadata agent and dhcp agent. I am trying to set up Ha for the network node using pacemaker.

In the suggestion in old question was to change the port number in the neutron-l3-agent to that of AMQP server. But there is no AMQP server in network node, AMQP server runs in the controller node. Anyway I will try that and Get back with more details.

rahulrajvn gravatar imagerahulrajvn ( 2014-07-19 13:51:29 -0600 )edit

By changing the port as told in that solution the error is gone but On testing the HA doesn't work. let me check more and get back, as of now this error is fixed.

rahulrajvn gravatar imagerahulrajvn ( 2014-07-21 10:57:46 -0600 )edit