Ask Your Question
0

Instance hostname not match with dns

asked 2014-07-18 09:24:25 -0600

HoangDo gravatar image

Hi guys,

I observed a strange thing happens on my instances: the hostname is not match with 127.0.0.1 IP in hosts:

  • /etc/hostname: mychefserver

  • /etc/hosts: 127.0.0.1 localhost

I used neutron gre network and ubuntu image

Do you have any idea what's wrong here?

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
2

answered 2014-07-22 20:52:37 -0600

don gravatar image

I think you have not run 'cloud-init'. Either you don't have 'cloud-init' installed, or you have not got it set to use the mechanism (e.g. config_drive, etc) that you have in use.

see /etc/cloud/cloud.cfg. What do you have for:

preserve_hostname: false
manage_etc_hosts: True
edit flag offensive delete link more

Comments

@don how to setup dnsmasq for the instances ? could you guide me

rajcoumar gravatar imagerajcoumar ( 2015-02-11 06:15:27 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-07-18 09:24:25 -0600

Seen: 562 times

Last updated: Jul 18 '14