Ask Your Question
1

No handlers could be found for logger "swiftclient"

asked 2013-08-20 10:01:05 -0600

baran gravatar image

updated 2013-08-21 09:46:08 -0600

Jobin gravatar image

I have a running instance of Keystone and Swift:

root@baran:/etc# keystone catalog  
Service: object-store

|-------------+-----------------------------------------------------------------|
| Property    | Value                                                           |
|-------------+-----------------------------------------------------------------|
| adminURL    | http://127.0.0.1:8888/v1                                        |
| internalURL | http:// 127.0.0.1:8888/v1/AUTH_ab6f8b28350e4669899d7690bf0b468e  |
| publicURL   | http:// 127.0.0.1:8888/v1/AUTH_ab6f8b28350e4669899d7690bf0b468e  |
| region      | RegionOne                                                       |
|-------------+-----------------------------------------------------------------|


 Service: identity

 |-------------+-----------------------------|
 | Property    | Value                       |
 |-------------+-----------------------------|
 | adminURL    | http://127.0.0.1:35357/v2.0 |
 | internalURL | http:// 127.0.0.1:5000/v2.0  |
 | publicURL   | http:// 127.0.0.1:5000/v2.0  |
 | region      | RegionOne                   |
 |-------------+-----------------------------|

but:

root@baran:/etc# swift -V 2.0 -A http://127.0.0.1:5000/v2.0 -U service:swift -K $ADMINPASS stat

No handlers could be found for logger "swiftclient"   
[errno 111] connection refused

root@baran:/etc# swift -V 2.0 -A http://127.0.0.1:5000/v2.0 -U  service:swift -K swiftadmin stat

No handlers could be found for logger "swiftclient"      
 [errno 111] connection refused

I was wrong in my endpoint (// in publicurl):

Before correction:

keystone endpoint-create \   
--region RegionOne \   
--publicurl=http: 127.0.0.1:5000/v2.0 \   
--internalurl=http:// 127.0.0.1:5000/v2.0 \   
--adminurl=http:// 127.0.0.1:35357/v2.0    

keystone endpoint-create \    
--region RegionOne \    
--publicurl 'http: 127.0.0.1:8888/v1/AUTH_%(tenant_id)s' \    
--internalurl 'http:// 127.0.0.1:8888/v1/AUTH_%(tenant_id)s' \    
--adminurl 'http:// 127.0.0.1:8888/v1'    

root@baran:/etc# swift -V 2.0 -A http://127.0.0.1:5000/v2.0 -U service:swift -K $ADMINPASS stat

error:

No handlers could be found for logger "swiftclient"   
 [errno -2] name or service not know

root@baran:/etc# swift -V 2.0 -A http://127.0.0.1:5000/v2.0 -U service:swift -K swiftadmin stat

error:

No handlers could be found for logger "swiftclient"     
[errno -3] temporary failure in name resolution

After correction:

keystone endpoint-create \ 
--region RegionOne \ 
--publicurl=http: //127.0.0.1:5000/v2.0 \ 
--internalurl=http:// 127.0.0.1:5000/v2.0 \ 
--adminurl=http:// 127.0.0.1:35357/v2.0 

keystone endpoint-create \ 
--region RegionOne \ 
--publicurl 'http: //127.0.0.1:8888/v1/AUTH_%(tenant_id)s' \ 
--internalurl 'http:// 127.0.0.1:8888/v1/AUTH_%(tenant_id)s' \ 
--adminurl 'http:// 127.0.0.1:8888/v1'

After correcting this error was:

root@baran:/etc# swift -V 2.0 -A http://127.0.0.1:5000/v2.0 -U service:swift -K $ADMINPASS stat 
and 
root@baran:/etc# swift -V 2.0 -A http://127.0.0.1:5000/v2.0 -U service:swift -K swiftadmin stat

error:

No handlers could be found for logger "swiftclient"   
[errno 111] connection refused

Could anyone help me with this? Thanks.

edit retag flag offensive close merge delete

Comments

I don't understand why you edited your question to change the error message you get. Are you getting the error message about `logger`? If not, what did you do to solve this? Please make an effort to keep a continuity in this question so others can benefit from it too.

rahmu gravatar imagerahmu ( 2013-08-21 02:15:52 -0600 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2013-08-21 04:02:08 -0600

rahmu gravatar image

When defining your endpoints, you have a space character between http:// and 127.0.0.1:.... That's probably causing your error.

edit flag offensive delete link more

Comments

Not. Here is a typographical error.

baran gravatar imagebaran ( 2013-08-21 05:33:31 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2013-08-20 10:01:05 -0600

Seen: 395 times

Last updated: Aug 21 '13