Ask Your Question
1

Nova related services are not starting and logs are not getting updated

asked 2013-08-20 09:59:15 -0500

iyyappan1985eee gravatar image

updated 2013-08-21 18:00:08 -0500

smaffulli gravatar image

We are setting up HA for nova. Nova is working fine in passive but stopped working in Active. We are in the process of installing OpenStack in HA. We are following the same steps in both the nodes, we don't know how come its working for passive and its not working for active. Nova active setup is same as Passive one. But must be some mis-configuration somewhere which I am unable to find out.

Found the below in logs

    raise ConfigFilesNotFoundError(not_read_ok)
oslo.config.cfg.ConfigFilesNotFoundError: Failed to read some config files: /etc/nova/nova.conf
Traceback (most recent call last):
  File "/usr/bin/nova-api", line 50, in <module>
    config.parse_args(sys.argv)
  File "/usr/lib/python2.7/dist-packages/nova/config.py", line 37, in parse_args
    default_config_files=default_config_files)
  File "/usr/lib/python2.7/dist-packages/oslo/config/cfg.py", line 1180, in __call__
    self._parse_config_files()
  File "/usr/lib/python2.7/dist-packages/oslo/config/cfg.py", line 1655, in _parse_config_files
    raise ConfigFilesNotFoundError(not_read_ok)
oslo.config.cfg.ConfigFilesNotFoundError: Failed to read some config files: /etc/nova/nova.conf

Have the below permissions

drwxr-xr-x 2 root root 4096 Aug 20 16:58 rootwrap.d
-rw-r--r-- 1 root root  934 Aug 20 16:58 rootwrap.conf
-rw-r--r-- 1 root root 1363 Aug 20 16:58 logging.conf
-rw-r----- 1 root root 3464 Aug 20 16:58 api-paste.ini
-rw-r----- 1 root root 7126 Aug 20 16:58 policy.json
-rw-r----- 1 root root  474 Aug 20 16:58 nova.conf.org
-rw-r----- 1 root root 1956 Aug 20 20:09 nova.conf

but this is same as passive..But passive is working fine

edit retag flag offensive close merge delete

Comments

Are you running nova as root user?

Jobin gravatar imageJobin ( 2013-08-20 14:22:16 -0500 )edit

2 answers

Sort by ยป oldest newest most voted
0

answered 2013-08-30 02:05:09 -0500

Anand TS gravatar image

try to run this debug command in active node in which nova services are stopped #/usr/bin/nova-compute --config-file /etc/nova/nova.conf

edit flag offensive delete link more
0

answered 2013-08-21 00:31:30 -0500

unmesh-gurjar gravatar image

updated 2013-08-21 00:32:53 -0500

I guess the error is because the user running the Compute service does not have permissions to read the nova.conf file. To confirm this, please try providing read permissions to all users for nova.conf file (by doing a 'chmod a+r nova.conf') and then try restarting the Nova service(s). Hope it helps!

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2013-08-20 09:59:15 -0500

Seen: 1,719 times

Last updated: Aug 30 '13