Ask Your Question
1

heat is not able to create stack with instack

asked 2014-07-18 06:10:40 -0600

peeyush gravatar image

updated 2014-07-21 00:42:19 -0600

Hi all,

I have been trying to set instack with RDO. I have successfully installed undercloud and moving on to overcloud. Now, when I run "instack-deploy-overcloud", I get the following error:

+ OVERCLOUD_YAML_PATH=overcloud.yaml
+ heat stack-create -f overcloud.yaml -P AdminToken=b003d63242f5db3e1ad4864ae66911e02ba19bcb -P AdminPassword=7bfe4d4a18280752ad07f259a69a3ed00db2ab44 -P CinderPassword=df0893b4355f3511a6d67538dd592d02d1bc11d3 -P GlancePassword=066f65f878157b438a916ccbd44e0b7037ee118f -P HeatPassword=58fda0e4d6708e0164167b11fe6fca6ab6b35ec6 -P NeutronPassword=80853ad029feb77bb7c60d035542f21aa5c24177 -P NovaPassword=331474580be53b78e40c91dfdfc2323578a035e7 -P NeutronPublicInterface=eth0 -P SwiftPassword=b0eca57b45ebf3dd5cae071dc3880888fb1d4840 -P SwiftHashSuffix=a8d87f3952d6f91da589fbef801bb92141fd1461 -P NovaComputeLibvirtType=qemu -P 'GlanceLogFile='\'''\''' -P NeutronDnsmasqOptions=dhcp-option-force=26,1400 overcloud
+--------------------------------------+------------+--------------------+----------------------+
| id                                   | stack_name | stack_status       | creation_time        |
+--------------------------------------+------------+--------------------+----------------------+
| 0ca028e7-682b-41ef-8af0-b2eb67bee272 | overcloud  | CREATE_IN_PROGRESS | 2014-07-18T10:50:48Z |
+--------------------------------------+------------+--------------------+----------------------+
+ tripleo wait_for_stack_ready 220 10 overcloud
Command output matched 'CREATE_FAILED'. Exiting...

Now, I understand that the stack isn't being created. So, I tried to check out the state of the stack:

[stack@localhost ~]$ heat stack-list
+--------------------------------------+------------+---------------+----------------------+
| id                                   | stack_name | stack_status  | creation_time        |
+--------------------------------------+------------+---------------+----------------------+
| 0ca028e7-682b-41ef-8af0-b2eb67bee272 | overcloud  | CREATE_FAILED | 2014-07-18T10:50:48Z |
+--------------------------------------+------------+---------------+----------------------+

I even tried to create stack manually, but ended up getting the same error.

Update: Here is the heat log:

2014-07-18 06:51:11.884 30750 WARNING heat.common.keystoneclient [-] stack_user_domain ID not set in heat.conf falling back to using default
2014-07-18 06:51:12.921 30750 WARNING heat.common.keystoneclient [-] stack_user_domain ID not set in heat.conf falling back to using default
2014-07-18 06:51:16.058 30750 ERROR heat.engine.resource [-] CREATE : Server "SwiftStorage0" [07e42c3d-0f1b-4bb9-b980-ffbb74ac770d] Stack "overcloud" [0ca028e7-682b-41ef-8af0-b2eb67bee272]
2014-07-18 06:51:16.058 30750 TRACE heat.engine.resource Traceback (most recent call last):
2014-07-18 06:51:16.058 30750 TRACE heat.engine.resource   File "/usr/lib/python2.7/site-packages/heat/engine/resource.py", line 420, in _do_action
2014-07-18 06:51:16.058 30750 TRACE heat.engine.resource     while not check(handle_data):
2014-07-18 06:51:16.058 30750 TRACE heat.engine.resource   File "/usr/lib/python2.7/site-packages/heat/engine/resources/server.py", line 545, in check_create_complete
2014-07-18 06:51:16.058 30750 TRACE heat.engine.resource     return self._check_active(server)
2014-07-18 06:51:16.058 30750 TRACE heat.engine.resource   File "/usr/lib/python2.7/site-packages/heat/engine/resources/server.py", line 561, in _check_active
2014-07-18 06:51:16.058 30750 TRACE heat.engine.resource     raise exc
2014-07-18 06:51:16.058 30750 TRACE heat.engine.resource Error: Creation of server overcloud-SwiftStorage0-qdjqbif6peva failed.
2014-07-18 06:51:16.058 30750 TRACE heat.engine.resource 
2014-07-18 06:51:16.255 30750 WARNING heat.common.keystoneclient [-] stack_user_domain ID not set in heat.conf falling back to using default
2014-07-18 06:51:16.939 30750 WARNING heat.common.keystoneclient [-] stack_user_domain ID not set in heat.conf falling back to using default
2014-07-18 06:51:17.368 30750 WARNING heat.common.keystoneclient [-] stack_user_domain ID not set in heat.conf falling back to using default
2014-07-18 06:51:17.638 30750 WARNING heat.common.keystoneclient [-] stack_user_domain ID not set in heat.conf falling back to using default
2014-07-18 06:51:18.158 30750 WARNING heat.common.keystoneclient [-] stack_user_domain ID not set in heat.conf falling back to using default
2014-07-18 06:51:18.613 30750 WARNING heat.common.keystoneclient [-] stack_user_domain ID not set in heat.conf falling back ...
(more)
edit retag flag offensive close merge delete

Comments

check the heat logs for more details, post it so we can further troubleshoot this issue

Syed Awais Ali gravatar imageSyed Awais Ali ( 2014-07-18 06:39:40 -0600 )edit

Hi, I have updated the heat log. Please have a look.

peeyush gravatar imagepeeyush ( 2014-07-21 00:42:58 -0600 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2014-07-21 01:38:30 -0600

updated 2014-07-21 01:38:54 -0600

I guess its a Bug. Pls see the following links. https://bugs.launchpad.net/tripleo/+b... and https://bugs.launchpad.net/tripleo/+b...

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-07-18 06:10:40 -0600

Seen: 453 times

Last updated: Jul 21 '14