Ask Your Question
0

Seeing python-pbr version conflict error in cinder-scheduler log

asked 2014-07-17 02:31:19 -0500

San thosh gravatar image

updated 2014-07-17 08:14:05 -0500

SamYaple gravatar image

Hi,

I installed Havana release of OpenStack on Ubuntu 12.04 machine and I am seeing VersionConflict error in cinder-scheduler logs. Due to it, create volume request fails.

Initially, I was seeing this error:

VersionConflict: (pbr 0.9.0 (/usr/local/lib/python2.7/dist-packages), Requirement.parse('pbr>=0.5,<0.6'))

So, I manually removed pbr 0.9.0 and installed pbr v0.5.21. Then I started getting this error:

VersionConflict: (pbr 0.5.21 (/usr/local/lib/python2.7/dist-packages), Requirement.parse('pbr>=0.6,!=0.7,<1.0'))

It looks so weird. Any help will be much appreciated. Thanks!

Here is full log of this error:

2014-07-16 15:37:05.360 1154 AUDIT cinder.service [-] SIGTERM received
2014-07-16 15:41:43.732 1182 ERROR stevedore.extension [-] Could not load 'CapabilitiesFilter': (pbr 0.5.21 (/usr/local/lib/python2.7/dist-packages), Requirement.parse('pbr>=0.6,!=0.7,<1.0'))
2014-07-16 15:41:43.798 1182 ERROR stevedore.extension [-] (pbr 0.5.21 (/usr/local/lib/python2.7/dist-packages), Requirement.parse('pbr>=0.6,!=0.7,<1.0'))
2014-07-16 15:41:43.798 1182 TRACE stevedore.extension Traceback (most recent call last):
2014-07-16 15:41:43.798 1182 TRACE stevedore.extension   File "/usr/lib/python2.7/dist-packages/stevedore/extension.py", line 89, in _load_plugins
2014-07-16 15:41:43.798 1182 TRACE stevedore.extension     invoke_kwds,
2014-07-16 15:41:43.798 1182 TRACE stevedore.extension   File "/usr/lib/python2.7/dist-packages/stevedore/extension.py", line 101, in _load_one_plugin
2014-07-16 15:41:43.798 1182 TRACE stevedore.extension     plugin = ep.load()
2014-07-16 15:41:43.798 1182 TRACE stevedore.extension   File "/usr/lib/python2.7/dist-packages/pkg_resources.py", line 1988, in load
2014-07-16 15:41:43.798 1182 TRACE stevedore.extension     if require: self.require(env, installer)
2014-07-16 15:41:43.798 1182 TRACE stevedore.extension   File "/usr/lib/python2.7/dist-packages/pkg_resources.py", line 2001, in require
2014-07-16 15:41:43.798 1182 TRACE stevedore.extension     working_set.resolve(self.dist.requires(self.extras),env,installer))
2014-07-16 15:41:43.798 1182 TRACE stevedore.extension   File "/usr/lib/python2.7/dist-packages/pkg_resources.py", line 588, in resolve
2014-07-16 15:41:43.798 1182 TRACE stevedore.extension     raise VersionConflict(dist,req) # XXX put more info here
2014-07-16 15:41:43.798 1182 TRACE stevedore.extension VersionConflict: (pbr 0.5.21 (/usr/local/lib/python2.7/dist-packages), Requirement.parse('pbr>=0.6,!=0.7,<1.0'))
2014-07-16 15:41:43.798 1182 TRACE stevedore.extension 
2014-07-16 15:41:43.818 1182 ERROR stevedore.extension [-] Could not load 'AvailabilityZoneFilter': (pbr 0.5.21 (/usr/local/lib/python2.7/dist-packages), Requirement.parse('pbr>=0.6,!=0.7,<1.0'))
2014-07-16 15:41:43.818 1182 ERROR stevedore.extension [-] (pbr 0.5.21 (/usr/local/lib/python2.7/dist-packages), Requirement.parse('pbr>=0.6,!=0.7,<1.0'))
2014-07-16 15:41:43.818 1182 TRACE stevedore.extension Traceback (most recent call last):
2014-07-16 15:41:43.818 1182 TRACE stevedore.extension   File "/usr/lib/python2 ...
(more)
edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2014-07-17 08:15:31 -0500

SamYaple gravatar image

What repositories are you using? I believe this fix is in havana-updates from the ubuntu-cloud-archive repo.

edit flag offensive delete link more

Comments

I followed the steps mentioned in the OpenStack doc for (OPENSTACK INSTALLATION GUIDE FOR UBUNTU 12.04 (LTS) - HAVANA) .

As part of this, I have run the following commands which you are mentioning:

Install the Ubuntu Cloud Archive for Havana:

# apt-get install python-software-properties
# add-apt-repository cloud-archive:havana

.

Update the package database, upgrade your system, and reboot for all changes to take effect:

# apt-get update && apt-get dist-upgrade
# reboot
San thosh gravatar imageSan thosh ( 2014-07-18 01:50:04 -0500 )edit

Due to the fact you had version 0.9.0 on your system, this makes me think at one point you were running Ubuntu 14.10 prerelease as this is the only place you could have installed that package (unless you did it by hand). Even 14.04 only has version 0.7.0 of this packages. With that being said, this mean you probably have all kinds of packages out of whack on that system with it trying to cope with dependancies.

Can you tell me how version 0.9.0 of python-pbr got on the system?

SamYaple gravatar imageSamYaple ( 2014-07-18 08:12:04 -0500 )edit

Let me go through the doc for the list of commands which would have installed pbr of v0.9.0.

But one thing I could not understand is that why is it giving this error even after uninstalling v0.9.0. (pbr 0.5.21 (/usr/local/lib/python2.7/dist-packages), Requirement.parse('pbr>=0.6,!=0.7,<1.0'))

San thosh gravatar imageSan thosh ( 2014-07-18 08:20:28 -0500 )edit

I noticed that as well, but with one dependancies and updated package comes hundreds of seemingly irrelevant newpackages as well. The apt system is great at keeping systems running, but it is a pain to "downgrade".

SamYaple gravatar imageSamYaple ( 2014-07-18 08:36:14 -0500 )edit

Hi, . When I install python-cinderclient, pbr of higher version gets installed. . .

root@OpenStack:/home/# pip install python-cinderclient Downloading/unpacking python-cinderclient Downloading python-cinderclient-1.0.9.tar.gz (136Kb): 136Kb downloaded Running setup.py egg_info for package python-cinderclient [pbr] Processing SOURCES.txt warning: LocalManifestMaker: standard file '-c' not found

warning: no previously-included files found matching '.gitignore'
warning: no previously-included files found matching '.gitreview'
warning: no previously-included files matching '*.pyc' found anywhere in distribution
warning: no previously-included files found matching '.gitignore'
warning: no previously-included files found matching '.gitreview'

Downloading/unpacking pbr>=0.6,<1.0 (from python-cinderclient) Downloading pbr-0.10.0.tar.gz (77Kb): 77Kb downloaded Running setup.py egg_info for package pbr [pbr] Processing SOURCES.txt warning: LocalManifestMaker: standard file '-c' not found ..............

San thosh gravatar imageSan thosh ( 2014-07-24 06:35:03 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-07-17 02:31:19 -0500

Seen: 1,404 times

Last updated: Jul 17 '14