Ask Your Question

ovs_neutron_agent out of sync with plugin, agent tunnel out of sync with plugin

asked 2014-07-17 01:13:42 -0500

dwyaneini gravatar image

updated 2014-07-17 19:56:57 -0500

I'm deploying openstack icehouse version with three-node architecture (controller node, network node, and compute node1) on Debian wheezy.I use ml2 plugin and gre type driver.

Now, I notice some exceptions information in both the ovs-agent.log of network node and compute node.

2014-07-16 01:55:37.756 29090 INFO neutron.plugins.openvswitch.agent.ovs_neutron_agent [req-185a38a4-7c00-4af6-ba83-b1872eb34bbd None] Agent initialized successfully, now running...
2014-07-16 01:55:37.762 29090 INFO neutron.plugins.openvswitch.agent.ovs_neutron_agent [req-185a38a4-7c00-4af6-ba83-b1872eb34bbd None] Agent out of sync with plugin!
2014-07-16 01:55:37.763 29090 INFO neutron.plugins.openvswitch.agent.ovs_neutron_agent [req-185a38a4-7c00-4af6-ba83-b1872eb34bbd None] Agent tunnel out of sync with plugin!
2014-07-16 01:55:37.778 29090 INFO neutron.openstack.common.rpc.common [req-185a38a4-7c00-4af6-ba83-b1872eb34bbd None] Connected to AMQP server on

From , & . the first link prompts to add tcp connection in iptables, but I disable firewall rules. So this does not work.

Also, I refer as to source code of neutron ( ), but have no idea.

I just want to understand why this information exists and then eliminate the information. Thanks in advance.

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted

answered 2014-07-18 08:40:36 -0500

Hi, dwyaneini. It's my understanding -- I read about it in the last two weeks or so -- that when the agents first boot up, they are out of sync. And that's normal behaviour. Then they do synchronize, but no message is written back in the logs, AFAIK. Regrettably, I don't remember whether I read it here on Ask OpenStack, on a mailing list, or elsewhere.

edit flag offensive delete link more


Thanks for your response, gkeller2. Through reading the source code of this part, I agree with you. When the agent first boots up, it must execute the code "Agent out of sync with plugin!", then set the state to "false", and do synchronize. Firstly, I make a mistake that misunderstand this info show up every time

dwyaneini gravatar imagedwyaneini ( 2014-07-21 01:34:06 -0500 )edit

@dwyaneini, glad I could help with the little I know. =)

gkeller2 gravatar imagegkeller2 ( 2014-07-21 09:15:10 -0500 )edit

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower


Asked: 2014-07-17 01:13:42 -0500

Seen: 7,504 times

Last updated: Jul 18 '14