Ask Your Question
0

How to stop keystone?

asked 2014-07-16 23:27:31 -0500

anhdenday gravatar image

updated 2014-07-16 23:29:31 -0500

Dear all,

I am running OpenStack with DevStack, so that keystone service also running, I've checked it with command below

cd keystone
tools/with_venv.sh bin/keystone-all

It's appear an error

2014-07-17 11:15:09.421 16636 CRITICAL keystone [-] error: [Errno 98] Address already in use

So that it's already running by DevStack, now i want to stop it, how can i do? Can i check it by process id of keystone service after that kill -9 keystone_process_id or i have to do with another specify command to stop it? Because in official site of keystone developer I only see how to start it but stop i did not see?

http://docs.openstack.org/developer/keystone/developing.html

Thanks you so much

edit retag flag offensive close merge delete

5 answers

Sort by ยป oldest newest most voted
2

answered 2014-07-17 11:55:34 -0500

updated 2014-07-17 12:02:53 -0500

Are you using latest devstack?. As of last week devstack is running keystone under Apache.   You can stop keystone by doing 
service apache2 stop/start/restart.

Check ps -fe | grep -i apache.  If keystone is under Apache, then it will be listed there.
edit flag offensive delete link more
1

answered 2014-07-17 01:32:19 -0500

SGPJ gravatar image

By S.A.Ali: Try this command /etc/init.d/openstack-keystone status this will tell you the status and process id. Now you can stop it by running the command /etc/init.d/openstack-keystone stop after you are finished you can again restart it by replacing stop with restart execute this command to verify if keystone is running ps -ef | grep -i keystone-all. Hope that helps!!

edit flag offensive delete link more
0

answered 2014-07-17 00:22:42 -0500

Alex Z gravatar image

updated 2014-07-17 00:23:24 -0500

Maybe some other processes use this port? To see listened ports and PIDs of process which use it run this command under root

netstat -lnp
edit flag offensive delete link more
0

answered 2014-07-17 10:44:47 -0500

Error maybe due to the MySQL DB is running in backgrond.

Login from root.

1st; stop the keystone service. #/etc/init.d/openstack-keystone stop

2nd; start the keystone service again; #/etc/init.d/openstack-keystone start

If you got the previous error again. then the mysql db service should be running. so stop it. in centos. use; #service mysqld stop if u get any abnormal errors. then try to find if any available services; #ps -ef|grep -i mysql if any try to login to the db with admin rights to shutdown the db. if not kill the process(not recommend for production). try to start the mysql db service only for testing; #service mysqld start if everything goes well then stop the mysqldb service; #service mysqld stop Now you ready to start the keystone service; #/etc/init.d/openstack-keystone start

Everything should be fine now.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-07-16 23:27:31 -0500

Seen: 6,835 times

Last updated: Jul 17 '14