Ask Your Question
1

Keystone service status is always stopping/waiting

asked 2014-07-16 05:53:10 -0500

I am following http://docs.openstack.org/havana/install-guide/install/apt/content/keystone-install.html (this) documentation for keystone installation/configuration. Everything went well but service keystone status always shows keystone stop/waiting. When i tried to restart service using service keystone restart it shows

stop: Unknown instance
keystone: start /running process 3524

I am using Ubuntu 12.04 64 bit. I had also tried restarting VM but problem is still there. Note Keystone log file dont show any errors.

edit retag flag offensive close merge delete

Comments

I am getting the same problem and I am trying to install JUNO. If you get a solution for this please share.

humblearner gravatar imagehumblearner ( 2014-07-21 12:19:51 -0500 )edit

i have same problem. Did you solve ? if you get solution please share

Mazaher gravatar imageMazaher ( 2014-11-20 01:13:03 -0500 )edit

5 answers

Sort by ยป oldest newest most voted
0

answered 2014-09-02 06:22:17 -0500

I don't know what exactly the problem was but removing keystone and re installing worked for me.

edit flag offensive delete link more
0

answered 2015-08-28 15:37:16 -0500

Keystone is run through wsgi_mod so you only need to have apache running. When apache is active it will use the wsgi module to take keystone requests and server out tickets.

edit flag offensive delete link more
0

answered 2015-01-21 14:54:20 -0500

harti gravatar image

Comment "driver = keystone.token.persistence.backends.sql.Token" of the [token] section in the /etc/keystone/keystone.conf file

edit flag offensive delete link more
0

answered 2014-08-25 10:26:09 -0500

Akshay Patil gravatar image

updated 2014-08-25 10:28:28 -0500

This is due to keystone is not getting started properly and therefore port 35357 is not in listening mode. This seems to be anomalous behavior of service keystone. I am mentioning steps which have worked on my system for havana installtion on Ubuntu 12.04 Kernel version 3.2.0-67-generic. After a day of headache around this issue. Try these steps, preferably in the same order.

1) Remove keystone package:-

  apt-get remove  keystone

2) Reboot your system

 reboot

3) After reboot again INSTALL KEYSTONE.

apt-get install keystone

4) Check status of keystone service

 service keystone status

It will show start/running

5) Now do the necessary changes you want to do in /etc/keystone/keystone.conf

after making changes in conf file DO NOT RESTART KEYSTONE SERVICE

Use stop and start command to make an effect of restart but don't restart.

service keystone stop

service keystone start

For further help, pasting a dump of my CLI :-

Setting up keystone (1:2013.2.3-0ubuntu1~cloud0) ...
keystone start/running, process 1490
root@controller:~# vim /etc/keystone/keystone.conf
root@controller:~# export SERVICE_ENDPOINT=http://controller:35357/v2.0
root@controller:~# export SERVICE_TOKEN=123456
root@controller:~# service keystone status
keystone start/running, process 1490
root@controller:~# keystone tenant-create --name=admin --description="Admin Tenant"
Invalid OpenStack Identity credentials.
root@controller:~# service keystone stop
keystone stop/waiting
root@controller:~# service keystone start
keystone start/running, process 1516
root@controller:~# keystone tenant-create --name=admin --description="Admin Tenant"

+-------------+----------------------------------+
|   Property  |              Value               |
+-------------+----------------------------------+
| description |           Admin Tenant           |
|   enabled   |               True               |
|      id     | 6f0a2e25312448959faae2170a49c145 |
|     name    |              admin               |
+-------------+----------------------------------+
edit flag offensive delete link more

Comments

I did these steps but don't work i am using ubuntu server

Mazaher gravatar imageMazaher ( 2014-11-20 01:10:30 -0500 )edit
0

answered 2015-06-07 02:50:12 -0500

Vikram gravatar image

Even re-installing failed. I'm running Ubuntu 14.02 server on a virtual box. I'm attaching a screenshot for your consideration.

My keystone.conf file has following entries:

admin_token = openstack [database] ... connection = mysql://keystone:openstack@controller/keystone [token] ... provider = keystone.token.providers.uuid.Provider driver = keystone.token.persistence.backends.sql.Token [revoke] ... driver = keystone.contrib.revoke.backends.sql.Revoke [DEFAULT] ... verbose = True

The DNS is also not a problem, as it is resolving the 'controller' ip address.

Akshay/anybody .. Please help me. I'm stuck on this for over a month now.

Regards,

--V

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-07-16 05:53:10 -0500

Seen: 9,336 times

Last updated: Sep 02 '14