horizon console displays blank screen with message: noVNC ready: native WebSockets, canvas rendering

asked 2013-08-18 17:42:42 -0500

netflare gravatar image

updated 2013-08-18 17:47:22 -0500

This occured either after an apt-get update / upgrade after adding the following to /etc/apt/sources.list.d/grizzly.list: deb http://archive.gplhost.com/debian grizzly main deb http://archive.gplhost.com/debian grizzly-backports main

...or after resolving my previous problem with suspended instances by tearing down the network configuration.

Either way, I no longer have console access to my instances - except one workstation in the office running Chrome (version 28.0.1500.95). All other PCs (with windows 7 using IE9/10, firefox, chrome) or other Ubuntu desktops running 13.04 with latest firefox and chrome. The console worked perfectly before update (or network tear-down). I have checked websockets is enabled on browsers and should work with noVNC.

I have checked my nova settings and all appears correct - must be correct as it works in Chrome! I would be grateful if anyone has the answer to this problem and can tell me what settings I need to change or what updates I need to install to get this working.

I can tell you novnc is running: ps -ef | grep novnc root 1923 1 0 21:49 ? 00:00:00 /bin/sh -e -c start-stop-daemon --start --chuid nova --exec /usr/bin/nova-novncproxy -- --config-file=/etc/nova/nova.conf /bin/sh nova 1924 1923 0 21:49 ? 00:00:00 /usr/bin/python /usr/bin/nova-novncproxy --config-file=/etc/nova/nova.conf nova 3625 1924 0 22:30 ? 00:00:00 [nova-novncproxy] <defunct> nova 3626 1924 0 22:30 ? 00:00:00 [nova-novncproxy] <defunct> nova 3627 1924 0 22:30 ? 00:00:00 [nova-novncproxy] <defunct> nova 3628 1924 0 22:30 ? 00:00:00 [nova-novncproxy] <defunct> nova 3629 1924 0 22:30 ? 00:00:00 [nova-novncproxy] <defunct> root 19317 10234 0 23:35 pts/18 00:00:00 grep --color=auto novnc</defunct></defunct></defunct></defunct></defunct>

and nova services are running: cd /etc/init.d/; for i in $( ls nova-* ); do sudo service $i status; done nova-api start/running, process 1808 nova-cert start/running, process 1822 nova-compute start/running, process 1842 nova-conductor start/running, process 1864 nova-consoleauth start/running, process 1887 nova-network start/running, process 1909 nova-novncproxy start/running, process 1923 nova-scheduler start/running, process 1950

Makes no difference if I restart novnc / nova or reboot server.

I am wondering if there has been a mysql update (table change?) or something not reported that means I have stale data that has not been reset in the nova database?

edit retag flag offensive close merge delete

Comments

I have tested my install process from scratch and can duplicate the problem. It is interesting that the same desktop still works ok - all other still show the error message. This demonstrates that the problem cannot be due to my network tear-down or some rogue database entries. It therefore must be due to grizzly-backports or some incompatibility with my configuration (setup and working before backport updates).

netflare gravatar imagenetflare ( 2013-08-21 15:38:31 -0500 )edit

2 answers

Sort by ยป oldest newest most voted
2

answered 2013-09-16 08:32:45 -0500

sph gravatar image

Are there any javascript errors that you are seeing? I was trying to do a setup on Debian Wheezy and I had the same error with the message canvas rendering but no output. I ran the javascript debugger and found that /usr/share/novnc/include/rfb.js had the following line: nova_token = token; while token was not being passed in. I commented out that line and then I could see the VM's console.

edit flag offensive delete link more

Comments

Yes, I've noticed this too - good to know that it works. Thanks Peter

Moss gravatar imageMoss ( 2013-09-17 00:46:25 -0500 )edit

Many thanks, Commenting out that line worked for me.

netflare gravatar imagenetflare ( 2013-09-18 06:33:01 -0500 )edit

Glad to be of help :)

sph gravatar imagesph ( 2013-09-19 08:10:13 -0500 )edit

thank you sph,you must genius

Cheering gravatar imageCheering ( 2013-10-08 02:16:42 -0500 )edit
0

answered 2013-09-16 03:10:29 -0500

Moss gravatar image

updated 2013-12-03 12:00:02 -0500

Hello,

I had exactly the same problem but only with below novnc's version:

root@controller:~# apt-cache policy novnc
    novnc:
      Installed: 1:0.4+dfsg+1+20130425+git4973b9cc80-1~bpo70+1
      Candidate: 1:0.4+dfsg+1+20130425+git4973b9cc80-1~bpo70+1
      Version table:
         1:0.4+dfsg+1+20130425+git4973b9cc80-1~bpo70+1 0
            500 http://archive.gplhost.com/debian/ grizzly/main amd64

The solution was to downgrade novnc:

root@controller:~# apt-cache policy novnc
    novnc:
      Installed: 2012.2~20120906+dfsg-0ubuntu4~cloud0
      Candidate: 1:0.4+dfsg+1+20130425+git4973b9cc80-1~bpo70+1
      Version table:
         1:0.4+dfsg+1+20130425+git4973b9cc80-1~bpo70+1 0
            500 http://archive.gplhost.com/debian/ grizzly/main amd64
     *** 2012.2~20120906+dfsg-0ubuntu4~cloud0 0
            500 http://ubuntu-cloud.archive.canonical.com/ubuntu/ precise-updates/grizzly/main amd64

root@controller:~# dpkg -s novnc
        Package: novnc
        Status: install ok installed
        Priority: optional
        Section: web
        Installed-Size: 324
        Maintainer: Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
        Architecture: amd64
        Version: 2012.2~20120906+dfsg-0ubuntu4~cloud0

I'm using grizzly's nova-novncproxy:

root@controller:~# apt-cache policy nova-novncproxy
nova-novncproxy:
  Installed: 1:2013.1.2-0ubuntu1~cloud0
  Candidate: 1:2013.1.2-0ubuntu1~cloud0
  Version table:
 *** 1:2013.1.2-0ubuntu1~cloud0 0
        500 http://ubuntu-cloud.archive.canonical.com/ubuntu/ precise-updates/grizzly/main amd64

VNC's section of Controller's nova.conf:

# VNC
novncproxy_base_url = http://10.28.8.64:6080/vnc_auto.html

VNC's section of Compute's nova.conf:

# VNC
novncproxy_base_url=http://10.28.8.64:6080/vnc_auto.html
vncserver_proxyclient_address=10.28.8.93
vncserver_listen=0.0.0.0

This is my topology: OpenStack OVS Multinode:

Hope it helps:)

Peter

edit flag offensive delete link more

Comments

How did you roll back apt-cache policy novnc? I tried doing apt-get and specify package and received: unmet dependencies: novnc : Depends: websockify ... Please advise

bgyako gravatar imagebgyako ( 2013-12-03 10:06:44 -0500 )edit

You can skip the downgrade - just comment nova_token = token; in /usr/share/novnc/include/rfb.js

Moss gravatar imageMoss ( 2013-12-03 11:57:34 -0500 )edit

I did and received Failed to connect to server (code: 1006)

bgyako gravatar imagebgyako ( 2013-12-03 13:27:31 -0500 )edit

If commenting nova_token does not work try to downgrade: 1)remove nova-novncproxy and novnc 2)install novnc=2012.2~20120906+dfsg-0ubuntu4~cloud0 3)install nova-novncproxy Sources are in my answer above - GL!

Moss gravatar imageMoss ( 2013-12-04 03:10:49 -0500 )edit

How do I specify which version to install when I do the apt-get command?

bgyako gravatar imagebgyako ( 2013-12-04 09:16:08 -0500 )edit

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2013-08-18 17:42:42 -0500

Seen: 10,332 times

Last updated: Dec 03 '13