Ask Your Question
2

'provider:network_type' of ext-net shows as 'local' instead of 'gre' [closed]

asked 2014-07-14 03:33:58 -0500

Hari gravatar image

I have successfully configured 3 node open stack set up. I could successfully launch instance. But there are problems in networking. The IP assigned to instance is not up. I have re checked my configurations. When I checked ext-net

neutron net-show 4fg13adf-5e0a-4e97-827f-f68a6b641345

+---------------------------+--------------------------------------+
| Field                     | Value                                |
+---------------------------+--------------------------------------+
| admin_state_up            | True                                 |
| id                        | 42ec3adf-5e0a-4e97-827f-f68a6b614260 |
| name                      | ext-net                              |
| provider:network_type     | local                                |
| provider:physical_network |                                      |
| provider:segmentation_id  |                                      |
| router:external           | True                                 |
| shared                    | True                                 |
| status                    | ACTIVE                               |
| subnets                   | 4a361eb9-4b4d-4ece-b253-b7c3f5540c6c |
| tenant_id                 | 65e095d1e8eb413082efa7e5df2abcec     |
+---------------------------+--------------------------------------+

I figured out that provider:network_type is local. But I think it should be gre. How can I change that? I have checked all configs. It is showing type_drivers = gre, tenant_network_types = gre. Please advice.

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by SamYaple
close date 2014-07-18 08:41:37.735656

Comments

Could you post /etc/neutron/ml2_inf.ini ; /etc/neutron/plugin.ini
$ neutron agent-list

dbaxps gravatar imagedbaxps ( 2014-07-14 03:46:13 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2014-07-18 03:31:30 -0500

Hari gravatar image

updated 2014-07-18 03:33:31 -0500

I forgot to restart some services after changing network_type. So it was taking default configs. The default type is local. After restarting all neutron services it is showing gre.

edit flag offensive delete link more

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-07-14 03:33:58 -0500

Seen: 81 times

Last updated: Jul 18 '14