Ask Your Question
0

unable to start rsync, keystone, swift

asked 2013-08-14 04:32:50 -0500

baran gravatar image

updated 2013-08-14 12:52:21 -0500

Jobin gravatar image

hello.

I am not able to start rsync service, I am facing the following error.

service rsync start  
rsync: unrecognized service

And:

$ for srv in api cert network objectstore scheduler compute ; do sudo service openstack-keystone-$srv status; done  
I am facing the following error:  
openstack-keystone-api: unrecognized service  
openstack-keystone-cert: unrecognized service  
openstack-keystone-network: unrecognized service  
openstack-keystone-obectstore: unrecognized service  
openstack-keystone-scheduler: unrecognized service  
openstack-keystone-compute: unrecognized service  
and: 

$ for srv in api cert network objectstore scheduler compute ; do sudo service openstack-swift-$srv status; done

I am facing the following error:

   openstack- swift -api: unrecognized service  
    openstack- swift -cert: unrecognized service  
    openstack- swift -network: unrecognized service  
    openstack- swift -obectstore: unrecognized service  
    openstack- swift -scheduler: unrecognized service  
    openstack-swift-compute: unrecognized service

and

apt-get updete     
W: failed to fetch http://ir.archive.ubuntu.com/ ubuntu/dists/precise-updates/......   
W: failed to fetch http://ir.archive.ubuntu.com/ ubuntu/dists/precise-backports/r......    
W: failed to fetch  
.   
.    
.  
W: some index files failed to download. They have been ignored, or old one used instead

while Previously, this worked.

please help me. thanks

edit retag flag offensive close merge delete

Comments

For the last error: Can you ping or connect to any website? Hope you don't have network issues.

Jobin gravatar imageJobin ( 2013-08-14 12:27:58 -0500 )edit

no. i can not. but i don't have network problem.

baran gravatar imagebaran ( 2013-08-14 13:42:03 -0500 )edit

Are you behind a proxy and have not configured /etc/apt/apt.conf?

Jobin gravatar imageJobin ( 2013-08-15 00:26:19 -0500 )edit

i don't have configured /etc/apt/apt. i installed other ubuntu on my vm, and replied with the same settings. but not work on my ubuntu.while Previously, this worked on my ubuntu. What is your opinion ??

baran gravatar imagebaran ( 2013-08-15 01:04:00 -0500 )edit

So are you behind a proxy server?

Jobin gravatar imageJobin ( 2013-08-20 14:14:14 -0500 )edit

2 answers

Sort by ยป oldest newest most voted
0

answered 2016-11-16 01:00:52 -0500

silently gravatar image

use this command:

rsync --daemon

edit flag offensive delete link more
0

answered 2013-08-22 12:44:52 -0500

clayg gravatar image

sudo apt-get install rsync

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2013-08-14 04:32:50 -0500

Seen: 796 times

Last updated: Aug 22 '13