Ask Your Question

ERROR: Unable to communicate with identity service

asked 2013-08-13 17:55:24 -0500

cs1989 gravatar image

Hi i have trying to install openstack using devstack but i am running into following error:

"keystone tenant-create --name admin grep ' id ' get_field 2 read data Unable to communicate with identity service The proxy could not connect to the destination in time. THIS PAGE IS NOT BLOCKED. The proxy tried to connect to the requested web server but was unable to open a connection. Usually this means that the server is down, but it might also be too busy to respond in time. Trying again might work (HTTP 502) "

I am trying to set this up behind a corporate proxy, and is it possible that the error is caused by keystone service isn't actually running and listening on the specified port because i found out that the url it was trying to request is:


Here is my keystone.conf:

      *admin_token = admintoken
      admin_endpoint = http://localhost:%(admin_port)s/
      public_endpoint = http://localhost:%(public_port)s/
      connection = mysql://root:password!@localhost/keystone?charset=utf8*

Any help is appreciated!

edit retag flag offensive close merge delete

4 answers

Sort by ยป oldest newest most voted

answered 2013-08-13 22:33:46 -0500

Jobin gravatar image

updated 2013-08-13 22:38:17 -0500

Since http 502 is a "Bad Gateway" error and you are behind a proxy server and trying to connect to localhost, it doesn't seem like you need to connect to your proxy server.

For this you need to add the following lines to the end of your /home/$USER/.bashrc:


Also, if your host cannot resolve localhost, you need to add this instead of the above line:


and then do a

source /home/$USER/.bashrc

before you reinstall using devstack( do a /<path>/ and then /<path>/

edit flag offensive delete link more


Please accept the answer if it has worked as you wanted.

Jobin gravatar imageJobin ( 2013-08-14 12:34:35 -0500 )edit

Hi, do you just mean clicking on the 'check mark' button? Sorry i am new to this

cs1989 gravatar imagecs1989 ( 2013-08-14 15:45:29 -0500 )edit

You did it right!

Jobin gravatar imageJobin ( 2013-08-15 00:08:47 -0500 )edit

answered 2013-08-14 10:45:57 -0500

cs1989 gravatar image

Thank you very much! That solved my problem!

edit flag offensive delete link more

answered 2013-08-13 21:59:27 -0500

Mathias Ewald gravatar image

Hi, first thing I would check is whether the keystone services are running.

root@keystone:~# netstat -tulpen 
Active Internet connections (only servers)
Proto Recv-Q Send-Q Local Address           Foreign Address         State       User       Inode       PID/Program name
tcp        0      0 *               LISTEN      0          25618       16388/python    
tcp        0      0  *               LISTEN      0          25620       16388/python  

I think if you see a python process listening von ports 35357 and 5000 it should be okay. I am just learning OpenStack, too, so don't count on it. I found that starting the service with the init script oder service command returns sucessfully while you still see error messages in the logs and the service is not actually running because of an exception or so.

Also, my env variables look like this:

export OS_TENANT_NAME=admin
export OS_USERNAME=admin
export OS_PASSWORD=password
export OS_AUTH_URL="http://localhost:5000/v2.0/"
export OS_SERVICE_ENDPOINT="http://localhost:35357/v2.0"
export OS_SERVICE_TOKEN=password

so I don't have that /tenant that you use.

Maybe that helps, maybe not ^^


edit flag offensive delete link more


Thanks!! That definitely helped me during debugging process.

cs1989 gravatar imagecs1989 ( 2013-08-14 10:46:36 -0500 )edit

answered 2013-10-31 22:39:42 -0500

export is needed in no_proxy

edit flag offensive delete link more

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower


Asked: 2013-08-13 17:55:24 -0500

Seen: 5,101 times

Last updated: Oct 31 '13