Ask Your Question
0

VMs problems with libvirt

asked 2013-04-22 02:25:19 -0500

peppepetra gravatar image

updated 2013-08-23 03:30:47 -0500

Jobin gravatar image

Hi all, i have some problems with VM connectivity.

After the creation of the VM i can ping the VM only with his private ip from the compute host. If I connect to the vnc server i find that the vm does not have active network connection. In the libvirt log of the host i find the following error messages:

2013-04-19 07:43:55.631+0000: 1161: error : virNetSocketReadWire:1006 : End of file while reading data: Input/output error
2013-04-19 07:45:55.630+0000: 1161: error : virNetSocketReadWire:1006 : End of file while reading data: Input/output error
2013-04-19 07:48:10.688+0000: 1161: error : virNetSocketReadWire:1006 : End of file while reading data: Input/output error
2013-04-19 07:50:19.756+0000: 1161: error : virNetSocketReadWire:1006 : End of file while reading data: Input/output error
2013-04-19 07:55:43.877+0000: 1165: error : virNWFilterDHCPSnoopEnd:2113 : internal error ifname "vnet0" not in key map
2013-04-19 07:55:43.891+0000: 1165: error : virNetDevGetIndex:657 : Unable to get index for interface vnet0: No such device
2013-04-19 08:13:00.454+0000: 7368: info : libvirt version: 0.9.13
2013-04-19 08:13:00.454+0000: 7368: error : virNWFilterSnoopLeaseFileRefresh:1882 : open("/var/run/libvirt/network/nwfilter.ltmp"): No such file or directory
2013-04-19 08:14:50.429+0000: 8019: info : libvirt version: 0.9.13
2013-04-19 08:14:50.429+0000: 8019: error : virNWFilterSnoopLeaseFileRefresh:1882 : open("/var/run/libvirt/network/nwfilter.ltmp"): No such file or directory

If i act as a member of a project I can not lunch a new instance. If I act as the admin user I can lunch the vm. The vm obtain the private ip. I can also associate a floating ip. I can access to the instance both through the private ip (through the compute host) and through the public ip from everywhere, but after loggin to the instance i don't have public access. I can't do ping google.it for example

Someone can help me? Thanks in advance!

edit retag flag offensive close merge delete

Comments

It looks like the host is misconfigured. Are there any other instances running from the same host ?

dachary gravatar imagedachary ( 2013-11-12 13:55:23 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2013-12-01 01:06:58 -0500

Euler gravatar image

Did you make wrong configration for the 'libvirtd_opts="-d -l" option? Use "-1" instead of "-l"? See the link: https://github.com/login?return_to=https%3A%2F%2Fgithub.com%2Fmseknibilel%2FOpenStack-Folsom-Install-guide%2Fissues%2Fnew my mistake instead the correct "-d -l" I have put the wrong chart "-d -1"

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2013-04-22 02:25:19 -0500

Seen: 2,741 times

Last updated: Aug 23 '13