Ask Your Question
1

External network Cannot ping vm successfully

asked 2013-08-08 01:42:12 -0500

tardis gravatar image

updated 2013-08-26 00:17:45 -0500

fifieldt gravatar image

My environment is ubuntu 13.04 64bit server and openstack grizzly, single node with OpenVSwitch. Here is my config:

/etc/network/interfaces

# The loopback network interface
auto lo
iface lo inet loopback

auto eth0
iface eth0 inet static
        address 10.2.0.41
        netmask 255.255.255.0
        gateway 10.2.0.1

# The primary network interface
auto eth1
iface eth1 inet manual
        up ifconfig $IFACE 0.0.0.0 up
        down ifconfig $IFACE down

auto br-ex
iface br-ex inet static
        address 10.2.0.36
        netmask 255.255.255.0
        network 10.2.0.0
        broadcast 10.2.0.255
        gateway 10.2.0.1
        # dns-* options are implemented by the resolvconf package, if installed
        dns-nameservers 61.147.37.1

/etc/quantum/plugins/openvswitch/ovs_quantum_plugin.ini

#Under the database section
[DATABASE]
sql_connection = mysql://quantumUser:quantumPass@10.2.0.41/quantum

#Under the OVS section
[OVS]
tenant_network_type = gre
tunnel_id_ranges = 1:1000
integration_bridge = br-int
tunnel_bridge = br-tun
local_ip = 10.2.0.41
enable_tunneling = True

#Firewall driver for realizing quantum security group function
[SECURITYGROUP]
firewall_driver = quantum.agent.linux.iptables_firewall.OVSHybridIptablesFirewallDriver

I have two vms, 10.2.0.51 and 10.2.0.52 of floatingip, 192.168.100.2 and 192.168.100.3 of internal ip. In vm, I can ping both floatingip and internal ip succcessfully, but the vm cannot reach external network and either external network. I cannot ping successfully 10.2.0.50 that is the router gateway.

edit retag flag offensive close merge delete

Comments

Please post ovs-vsctl show output

Ashokb gravatar imageAshokb ( 2013-08-09 03:05:31 -0500 )edit

Did you try to set up your eth1 in promiscuous mode ? I think this is needed (yet, I don't know if it will solve the problem). You should add the following line in your /etc/network/interfaces: up ifconfig eth1 promisc

perror gravatar imageperror ( 2013-08-30 04:45:59 -0500 )edit

Check ovs-vsctl show comand, also check security lists. Try to listen interfaces with tcpdump

gagarinq9 gravatar imagegagarinq9 ( 2014-09-15 10:14:03 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2014-10-30 06:49:15 -0500

Vinod Pandarinathan gravatar image

Can you check ovs-vsctl show, if your eth0 is attached to br-ex then you can try changing local_ip to the ip address of br-ex and restart the neutron service and l2 agent service.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

2 followers

Stats

Asked: 2013-08-08 01:42:12 -0500

Seen: 542 times

Last updated: Aug 08 '13