Ask Your Question
2

How to solve error "failed to set bridge Ethernet address" with Neutron and OVS?

asked 2013-08-07 14:06:17 -0500

fm255005 gravatar image

updated 2013-08-08 17:26:52 -0500

smaffulli gravatar image

So I'm new to Quantum but have been working with Openstack since Essex. There is one thing that I cannot seem to wrap my head around which are the Quantum network types. Coming from Nova Networking these options are a lot more detailed then what was available though Nova. I guess I'm trying to find out which would fit my setup best.

Configuration:

  • 1 - Cloud Controller
  • 1 - Network Node
  • 7 - Compute Nodes
  • /23 public (access) IP range
  • Unlimited NIC cards (If I need more I can add more, but have tried with 3)
  • 48 port Cisco Switch

Questions that I have

Types: - Local - Is this setting only for single node installations? Successfully setup an all-in-one Openstack node but networking fails when I add another node.
- Flat - Initial figured this will work but see no documentation whatsoever on setting up Flat. - VLAN - If I have to I guess I can setup a VLAN but would rather not have to deal with contacting the network engineer. If I had access to the Cisco switch I would probably go down this route but I am still open to the idea of setting up a VLAN if its the easiest route. - GRE - don't know much about GRE networks and tunneling and see that tunneling requires you build from source. If it proves to be the easiest route then I can also do down this route.

Information

Issue

Everytime I start openvswith I get the following error message.

2013-08-07T18:45:07Z|00002|worker(worker)|INFO|worker process started
2013-08-07T18:45:07Z|00002|reconnect|INFO|unix:/var/run/openvswitch/db.sock: connecting...
2013-08-07T18:45:07Z|00003|reconnect|INFO|unix:/var/run/openvswitch/db.sock: connected
2013-08-07T18:45:07Z|00004|netdev_linux|ERR|ioctl(SIOCSIFHWADDR) on br-int device failed: Device or resource busy
2013-08-07T18:45:07Z|00005|bridge|ERR|bridge br-int: failed to set bridge Ethernet address: Device or resource busy
2013-08-07T18:45:07Z|00006|bridge|INFO|bridge br-int: using datapath ID 0000d62c8e91cc45
2013-08-07T18:45:07Z|00007|connmgr|INFO|br-int: added service controller "punix:/var/run/openvswitch/br-int.mgmt"
2013-08-07T18:45:07Z|00008|bridge|INFO|ovs-vswitchd (Open vSwitch) 1.10.0
2013-08-07T18:45:17Z|00009|memory|INFO|7724 kB peak resident set size after 10.0 seconds
2013-08-07T18:45:17Z|00010|memory|INFO|ports:1 rules:3
edit retag flag offensive close merge delete

Comments

I've tried multiple different network types and all of them give the same error as listed above with just the bridge name that changes. Either I'm looking to deep in to this error or something is wrong. I have a dev env. that does not give this error when starting openvswitch Change the bridge

fm255005 gravatar imagefm255005 ( 2013-08-08 10:03:15 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
3

answered 2013-08-08 04:07:11 -0500

darragh-oreilly gravatar image

updated 2013-08-09 03:50:39 -0500

It seems you would prefer to use flat networking. Here are steps to create a flat network with the symbolic name flatnet1.

The ovs_quantum_plugin.ini on the node running the Quantum server needs:

network_vlan_ranges = flatnet1

The ovs_quantum_plugin.ini on the network and compute nodes need:

bridge_mappings = flatnet1:br-flatnet1

On the network and compute nodes, create a bridge named br-flatnet1 and add the interface for the physical nic to it, eg:

# ovs-vsctl add-br br-flatnet1
# ovs-vsctl add-port br-flatnet1 eth3

These physical NICs should be plugged into switch ports in the same VLAN. Configure your network startup scripts to put these interfaces UP without an IP address at boot. Now create the flat network in Quantum:

$ quantum net-create fnet1 --provider:network_type flat \
  --provider:physical_network flatnet1 --shared

$ quantum subnet-create fnet1 10.0.1.0/24

As you are only doing flat networking, maybe it would be easier to use the Linux Bridge plugin instead of OVS.

For the error see here. What OS/kernel are you on? The workaround is to add ovs_use_veth = True to l3_agent.ini, dhcp_agent.ini and lbaas_agent.ini. I don't think it will solve the error about changing the mac on br-int, but you can probably ignore that as I don't think the mac on the bridge matters. But it is important for the router and dhcp devices because it is causing exceptions in the agents.

edit flag offensive delete link more

Comments

CentOS 6.4 kernel: 2.6.32-358.114.1.openstack.el6.x86_64 I do have ovs_use_veth set to true in all of the agents but I'm still getting the error. I'll give changing the mac address a try.

fm255005 gravatar imagefm255005 ( 2013-08-09 08:18:06 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

3 followers

Stats

Asked: 2013-08-07 14:06:17 -0500

Seen: 1,302 times

Last updated: Aug 09 '13