Ask Your Question
0

When I associate floating IP, ip addr is not running on the network node

asked 2013-08-04 06:15:55 -0500

bsolie gravatar image

Hi all,

I am trying to associate a floating IP with an existing instance. I am running Xen hypervisor and nova network on ubuntu 12.04 and grizzly. I can create the floating IP range, but when I associate the IP with an instance, the firewall rules get added but the IP is not bound to the public interface. ip addr show <dev> does not show the public IP on the network node.

Any thoughts?

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2013-10-24 08:28:15 -0500

dasp gravatar image

It should not be visible there.

In most cases, where OpenVSwitch driver is used, the br-ex interface is in promiscuous mode, listening to all traffic. It doesn't need to have IPs set to it. It captures all network traffic and routes it through IPtables.

If floating IP addresses don't work for you, make sure you have the br-ex up in promisc. Here is my interface config:

# Public interface for br-ex
allow-hotplug eth2
auto eth2
iface eth2 inet manual
    up ip addr add 0.0.0.0 dev eth2
    up ip link set eth2 promisc on
    up ip link set eth2 up
    up route add default gw 192.168.0.1 dev eth2
    up ip link set br-ex up

Note: This assumes you are using OpenVSwitch + GRE tunnels as your networking solution.

edit flag offensive delete link more

Comments

The question is about nova-network, not quantum/neutron.

darragh-oreilly gravatar imagedarragh-oreilly ( 2013-10-24 08:57:14 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2013-08-04 06:15:55 -0500

Seen: 318 times

Last updated: Oct 24 '13