Ask Your Question
0

No swift endpoint after devstack installation

asked 2013-07-31 19:50:01 -0500

highlife gravatar image

I installed swift and keystone using the following localrc: disable_all_services enable_service key mysql s-proxy s-object s-container s-account DATABASE_PASSWORD=asdf SERVICE_TOKEN=asdf SERVICE_PASSWORD=asdf ADMIN_PASSWORD=asdf SWIFT_HASH=asdf

I then authenticated using:

curl -d '{"auth":{"passwordCredentials":{"username": "admin", "password": "asdf"}}}' -H "Content-type: application/json" http://serverip:5000/v2.0/tokens

And got:

{"access": {"token": {"issued_at": "2013-08-01T00:31:27.570834", "expires": "2013-08-02T00:31:27Z", "id": "MIIC8QYJKoZIhvcNAQcCoIIC4jCCAt4CAQExCTAHBgUrDgMCGjCCAUcGCSqGSIb3DQEHAaCCATgEggE0eyJhY2Nlc3MiOiB7InRva2VuIjogeyJpc3N1ZWRfYXQiOiAiMjAxMy0wOC0wMVQwMDozMToyNy41NzA4MzQiLCAiZXhwaXJlcyI6ICIyMDEzLTA4LTAyVDAwOjMxOjI3WiIsICJpZCI6ICJwbGFjZWhvbGRlciJ9LCAic2VydmljZUNhdGFsb2ciOiBbXSwgInVzZXIiOiB7InVzZXJuYW1lIjogImFkbWluIiwgInJvbGVzX2xpbmtzIjogW10sICJpZCI6ICJlNDQ2ZTk4MTI3ZDM0YzA3ODBhZjQ3MjMyOTFjZTE2MiIsICJyb2xlcyI6IFtdLCAibmFtZSI6ICJhZG1pbiJ9LCAibWV0YWRhdGEiOiB7ImlzX2FkbWluIjogMCwgInJvbGVzIjogW119fX0xggGBMIIBfQIBATBcMFcxCzAJBgNVBAYTAlVTMQ4wDAYDVQQIEwVVbnNldDEOMAwGA1UEBxMFVW5zZXQxDjAMBgNVBAoTBVVuc2V0MRgwFgYDVQQDEw93d3cuZXhhbXBsZS5jb20CAQEwBwYFKw4DAhowDQYJKoZIhvcNAQEBBQAEggEAa+uMxsn2obzoiz6lV4FBQLGwv3rjSjNR3KoUA4doUotSo1xhav5Rq6+8vLgXlwN7ed+JAvoGiISicsTWnfnmCjBJYAKbIulenC3pzLoXj4fQFShuhzFDRgzhyQIw3lW6XQyydZIyXEl-UfgMMhav3QeszdbquNWCyJd--cl0e2skrIIPfALyVF4bO24PpuU2J3YZcm4NIxhJsy2adnLtyK-mIfGk8TItHwkBfb7yQozHB+WsRvI2h1u9c6St5v8Qn17Br-MvmMb9HBi5XGa-IBnjlXObFgOcqolUiTKS8+B3BXgOuvT9HAYmA04qTQco9+5fGlFqDRZeZofhcdGqdA=="}, "serviceCatalog": [], "user": {"username": "admin", "roles_links": [], "id": "e446e98127d34c0780af4723291ce162", "roles": [], "name": "admin"}, "metadata": {"is_admin": 0, "roles": []}}}%

I assume that there is supposed to be a swift endpoint in the serviceCatalog but it seems to be empty. Am I doing something wrong?

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
3

answered 2013-08-01 03:49:45 -0500

clayg gravatar image

Try adding "tenantName"

Here's my localrc:

DATABASE_PASSWORD=admin
RABBIT_PASSWORD=admin
SERVICE_TOKEN=admin
SERVICE_PASSWORD=admin
ADMIN_PASSWORD=admin
SWIFT_HASH=admin
ENABLED_SERVICES=key,swift,mysql

And my curl foo:

curl -d '{"auth":{"passwordCredentials":{"username": "admin", "password": "admin"}, "tenantName": "admin"}}' -H "Content-type: application/json" <a href="http://localhost:5000/v2.0/tokens">http://localhost:5000/v2.0/tokens</a> | python -m json.tool

You should also just try using environment vars and the swift command line tool:

source ./devstack/openrc
swift stat -v`
edit flag offensive delete link more

Comments

I believe it's tenantId, not tenantName. Also why is the tenantId required? Why can't I see the endpoints with just the username and password credentials?

highlife gravatar imagehighlife ( 2013-08-01 16:49:27 -0500 )edit

tenantName worked on my machine. Ask the Keystone guys why it's required all I know is: "cause roles"

clayg gravatar imageclayg ( 2013-08-01 17:11:48 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2013-07-31 19:50:01 -0500

Seen: 483 times

Last updated: Aug 01 '13