Ask Your Question
0

Unable to connect to AMQP server: [Errno 111] ECONNREFUSED. Sleeping 5 seconds [closed]

asked 2014-07-09 04:30:50 -0500

achutha gravatar image

in fedora while starting the scheduler service in nova i got messages like this when i gave tail -f /var/log/nova/scheduler.log

2014-07-09 15:00:16.117 9486 DEBUG qpid.messaging.io.raw [-] OPEN[403a680]: localhost:5672 connect /usr/lib/python2.7/site-packages/qpid/messaging/driver.py:528 2014-07-09 15:00:16.122 9486 ERROR nova.openstack.common.rpc.impl_qpid [req-97e0ab94-031c-4da8-a5f5-11f06103be9c None None] Unable to connect to AMQP server: [Errno 111] ECONNREFUSED. Sleeping 5 seconds

edit retag flag offensive reopen merge delete

Closed for the following reason duplicate question by koolhead17
close date 2014-08-10 17:17:31.704476

3 answers

Sort by ยป oldest newest most voted
1

answered 2014-07-09 04:52:25 -0500

dbaxps gravatar image
edit flag offensive delete link more
0

answered 2014-07-09 05:48:14 -0500

Anand TS gravatar image

Hi Arun,

Check your messaging service (qpidd/rabbitmq) is running fine.

edit flag offensive delete link more
0

answered 2014-07-09 08:59:35 -0500

Eric Xie gravatar image

updated 2014-07-09 09:01:29 -0500

Hi,

Today i met one similar question. Compute node can not build link with controller node. Finally i found iptables firewall does not allow receiving messages from compute node. So i changed the rule to work on it.

Wish help~

edit flag offensive delete link more

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-07-09 04:30:50 -0500

Seen: 1,523 times

Last updated: Jul 09 '14