Keystone is not able to start ! Please help

asked 2013-07-29 11:55:02 -0500

Deepak gravatar image

updated 2013-07-29 13:54:23 -0500

Jobin gravatar image

Hi,

Can someone please help me sorting out this error ?

+ [[ PKI == \P\K\I ]]
+ rm -rf /etc/keystone/ssl
+ /opt/stack/keystone/bin/keystone-manage pki_setup
Traceback (most recent call last):
  File "/opt/stack/keystone/bin/keystone-manage", line 28, in <module>
    cli.main(argv=sys.argv, config_files=config_files)
  File "/opt/stack/keystone/keystone/cli.py", line 198, in main
    CONF.command.cmd_class.main()
  File "/opt/stack/keystone/keystone/cli.py", line 99, in main
    conf_pki.run()
  File "/opt/stack/keystone/keystone/common/openssl.py", line 149, in run
    self.build_ssl_config_file()
  File "/opt/stack/keystone/keystone/common/openssl.py", line 81, in build_ssl_config_file
    self._make_dirs(self.ssl_config_file_name)
  File "/opt/stack/keystone/keystone/common/openssl.py", line 64, in _make_dirs
    os.makedirs(dir, DIR_PERMS)
  File "/usr/lib/python2.7/os.py", line 150, in makedirs
    makedirs(head, mode)
  File "/usr/lib/python2.7/os.py", line 150, in makedirs
    makedirs(head, mode)
  File "/usr/lib/python2.7/os.py", line 150, in makedirs
    makedirs(head, mode)
  File "/usr/lib/python2.7/os.py", line 150, in makedirs
    makedirs(head, mode)
  File "/usr/lib/python2.7/os.py", line 150, in makedirs
    makedirs(head, mode)
  File "/usr/lib/python2.7/os.py", line 150, in makedirs
    makedirs(head, mode)
  File "/usr/lib/python2.7/os.py", line 157, in makedirs
    mkdir(name, mode)
OSError: [Errno 13] Permission denied: '/Users'
+ sudo mkdir -p /var/cache/keystone
+ sudo chown student /var/cache/keystone
+ rm -f '/var/cache/keystone/*'
+ start_keystone
+ local service_port=5000
+ is_service_enabled tls-proxy
+ services=tls-proxy
+ for service in '${services}'
+ [[ ,g-api,g-reg,key,n-api,n-crt,n-obj,n-cpu,n-net,n-cond,cinder,c-sch,c-api,c-vol,n-sch,n-novnc,n-xvnc,n-cauth,horizon,rabbit,tempest,mysql, =~ ,tls-proxy, ]]
+ [[ tls-proxy == \n\o\v\a ]]
+ [[ tls-proxy == \c\i\n\d\e\r ]]
+ [[ tls-proxy == \c\e\i\l\o\m\e\t\e\r ]]
+ [[ tls-proxy == \g\l\a\n\c\e ]]
+ [[ tls-proxy == \n\e\u\t\r\o\n ]]
+ [[ tls-proxy == \s\w\i\f\t ]]
+ [[ tls-proxy == s-* ]]
+ return 1
+ screen_it key 'cd /opt/stack/keystone && /opt/stack/keystone/bin/keystone-all --config-file /etc/keystone/keystone.conf --log-config /etc/keystone/logging.conf -d --debug'
+ SCREEN_NAME=stack
+ SERVICE_DIR=/opt/stack/status
++ trueorfalse True True
++ local default=True
++ local testval=True
++ [[ -z True ]]
++ [[ 0 no false False FALSE =~ True ]]
++ [[ 1 yes true True TRUE =~ True ]]
++ echo True
++ return
+ USE_SCREEN=True
+ is_service_enabled key
+ services=key
+ for service in '${services}'
+ [[ ,g-api,g-reg,key,n-api,n-crt,n-obj,n-cpu,n-net,n-cond,cinder,c-sch,c-api,c-vol,n-sch,n-novnc,n-xvnc,n-cauth,horizon,rabbit,tempest,mysql, =~ ,key, ]]
+ return 0
+ screen_rc key 'cd /opt/stack/keystone && /opt/stack/keystone/bin/keystone-all --config-file /etc/keystone/keystone.conf --log-config /etc/keystone/logging.conf -d --debug'
+ SCREEN_NAME=stack
+ SCREENRC=/home/student/devstack/stack-screenrc
+ [[ ! -e /home/student/devstack/stack-screenrc ]]
+ grep key /home/student/devstack/stack-screenrc
++ echo -ne '\015'
+ NL=$'\r'
+ echo 'screen -t key bash'
+ echo 'stuff "cd /opt/stack/keystone && /opt/stack/keystone/bin/keystone-all --config-file /etc/keystone/keystone.conf --log-config /etc/keystone/logging.conf -d --deb"'
+ [[ True = \T\r\u\e ]]
+ screen -S stack -X screen -t key
+ [[ -n ...
(more)
edit retag flag offensive close merge delete

3 answers

Sort by ยป oldest newest most voted
1

answered 2013-07-29 17:03:04 -0500

smaffulli gravatar image

The first error I see is this one:

OSError: [Errno 13] Permission denied: '/Users'

Maybe you can provide more details about your environment and the exact commands that cause such output.

edit flag offensive delete link more

Comments

1

@smafulli : I found the problem it is because the changes that I edit in /etc/keystone/keystone.conf is not getting implemented. Once I run ./stack.sh in devstack it is getting back to the original state without holding the changes made in the configuration file. Which is the exact problem stated above as permission denied for Users which is not in my system.Please help

Deepak gravatar imageDeepak ( 2013-07-30 06:12:37 -0500 )edit
1

answered 2013-07-29 13:53:29 -0500

Jobin gravatar image

updated 2013-07-29 14:07:46 -0500

Most probably you are behind a proxy and you need to add a line no_proxy=localhost,<ip_address_of_keystone_host> in your ~/.bashrc file(assuming you are using Ubuntu and bash as your shell).

Do not forget to do a source ~/.bashrc after you have added this line before you do ./unstack and ./stack. Hope this helps.

edit flag offensive delete link more

Comments

What is the keystone host and how do I find its ip-address? Thanks

brakende gravatar imagebrakende ( 2013-09-27 09:52:01 -0500 )edit
0

answered 2013-10-10 08:23:10 -0500

naveed gravatar image

add following line in the bashrc file.

command: nano /home/User_Name/bashrc

no_proxy="localhost,127.0.0.1,http://IP_address_of_machine:5000 (line) logout is required to apply changes. then run ./stack.sh for installation

edit flag offensive delete link more

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2013-07-29 11:55:02 -0500

Seen: 2,740 times

Last updated: Oct 10 '13