haproxy maxconn limit

asked 2014-07-08 05:19:16 -0500

nevzat gravatar image

Hi, I want to use load balance service on my system. More than 10,000 clients are simultaneously expected to connect to the system. Therefore, I want to share connection on virtual machines (3 or more) which running on on my system.I have already activated and configured my load balance service. I use TCP for mode and roundrubin for balance. When I tested more then 10000 client, totally 2000 clients are connected. While running LB service, it never goes over 2000 client, and not matter how many member are running on loadbalance service. (When LB service was stopped, count of connected clients are more than 2000 on just one VM) I have already changed maxconn value in /etc/haproxy/haproxy.cfg in default and my service section but nothing has changed. I have noticed that, there are other conf files in "/var/lib/neutron/lbaas/" for neutron-loadbalancer service for each pools. I tried to changed one of these files, I added maxconn value on default section in this file and restarted the services of neutron on network node. After restart the file, which I change before restart services, was overwritten and maxconn value was lost. My haproxy configuration file (/etc/haproxy/haproxy.cnf) is as follows.

global
log /dev/log   local0 info
    log /dev/log   local0 notice
    maxconn 10000
    chroot /etc/haproxy
    uid 99
    gid 99
    daemon
defaults
    log global
    mode tcp
    option tcplog
    option dontlognull
    retries 3
    option redispatch
    maxconn 10000
    contimeout 5000
    clitimeout 50000
    srvtimeout 50000
listen openfire 127.0.0.1:5222
    mode tcp
    option httpchk OPTIONS /http-bind/ HTTP/1.0
    balance roundrobin
    maxconn 10000
    server ubuntu1 10.10.10.40:5222 check port 7070 maxconn 10000
    server ubuntu2 10.10.10.42:5223 check port 7070 maxconn 10000

And the other conf. file , which is located in /var/lib/neutron/lbass/ is as follows (/var/lib/neutron/lbaas/27d613ec-2ab2-40e5-801d-4417f7018e00/conf);

global
  daemon
  user nobody
  group haproxy
  log /dev/log local0
  log /dev/log local1 notice
  stats socket /var/lib/neutron/lbaas/27d613ec-2ab2-40e5-801d-4417f7018e00/sock mode 0666 level user
defaults
  log global
  retries 3
  option redispatch
  timeout connect 5000
  timeout client 50000
  timeout server 50000
frontend 7d0f72a0-de66-4047-9881-104d8ed3542c
  option tcplog
  bind 10.0.0.20:5222
  mode tcp
  default_backend 27d613ec-2ab2-40e5-801d-4417f7018e00
  maxconn 10000
backend 27d613ec-2ab2-40e5-801d-4417f7018e00
   mode tcp
   balance roundrobin
   timeout check 5s
   appsession test len 56 timeout 3h
   server 3358d082-bf6f-476c-8bd1-8307c0586fda 10.0.0.14:5222 weight 1 check inter 5s fall 5

Does anyone know how to solve this issue? How can I increase count of connected clients? How can I changed maxconn value?

edit retag flag offensive close merge delete