Ask Your Question
0

Error while installing devstack on Ubuntu 12.04

asked 2013-07-26 15:32:49 -0500

dushyant gravatar image

I followed the instructions listed here: http://devstack.org/guides/single-vm.html

and ran ./stack.sh but it gives the following error:

+ cd /opt/stack/horizon
+ python setup.py egg_info
python: can't open file 'setup.py': [Errno 2] No such file or directory
+ sudo HTTP_PROXY= HTTPS_PROXY= NO_PROXY= python setup.py develop
python: can't open file 'setup.py': [Errno 2] No such file or directory
++ failed
++ local r=2
+++ jobs -p
++ kill
++ set +o xtrace
edit retag flag offensive close merge delete

3 answers

Sort by ยป oldest newest most voted
2

answered 2013-07-29 01:27:51 -0500

unmesh-gurjar gravatar image

I guess the root cause of the error could be some error when devstack tried to clone 'horizon'. I would suggest you try out cloning the repo manually (in '/opt/stack/horizon' directory), if it goes fine, just rerun the stack.sh script. If you face any issues cloning, resolve them and move ahead to running the stack.sh script.

edit flag offensive delete link more
0

answered 2014-07-28 07:54:55 -0500

naggappan gravatar image

updated 2014-07-28 08:02:11 -0500

There are lots of dependencies which will case devstack failure. Please try to run the following commands (which is given in devstack-gate) , then create stack user and install devstack.

https://github.com/openstack-infra/devstack-gate/blob/master/README.rst (https://github.com/openstack-infra/de...)

In the above devstack-gate community has few scripts which will full fill the requirements.

    apt-get install -y git \
    && git clone https://review.openstack.org/p/openstack-infra/config \
    && config/install_puppet.sh && config/install_modules.sh \
    && puppet apply --modulepath=/root/config/modules:/etc/puppet/modules \
    -e "class { openstack_project::single_use_slave: install_users => false,
    ssh_key => \"$( cat .ssh/authorized_keys )\" }" \
    && echo HostKey /etc/ssh/ssh_host_ecdsa_key >> /etc/ssh/sshd_config \
    && echo "jenkins ALL=(ALL) NOPASSWD:ALL" >> /etc/sudoers \
    && reboot

Note : This will remove password for your login. So if you are using ssh you can only use ssh key to login.

I have also written a blog for installing devstack in ubuntu 12.04 . You can go throught it also ,

https://naggappan.wordpress.com/2014/07/28/step-by-step-guide-to-install-devstack/ (https://naggappan.wordpress.com/2014/...)

edit flag offensive delete link more
0

answered 2013-07-29 18:13:47 -0500

MoizArif gravatar image

If you are behind a network having Proxies, you might want to manually set up proxy for both http and https (export http_proxy=http://a.b.c.d:8080). also make sure to have sufficient sudo/root privileges while running Devstack (may be run $ sudo ./stack.sh or in root mode #./stack.sh). Hope it Helps.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2013-07-26 15:32:49 -0500

Seen: 1,732 times

Last updated: Jul 28 '14