Ask Your Question
0

Keystone CLI : Unable to establish connection

asked 2014-07-03 17:27:33 -0500

anonymous user

Anonymous

Hi,

Keystone services have successfully started. I am able to access the following URL using wget however it fails when accessed from within command line. Any suggestion on addressing the issue is greatly appreciated.

I have disabled http_proxy. Thank you.

stack@ubuntu-openstack:~$ keystone --debug service-list

DEBUG:keystoneclient.session:REQ: curl -i -X GET http://ubuntu-openstack:35357/v2.0/OS-KSADM/services (http://ubuntu-openstack:35357/v2.0/OS...) -H "User-Agent: python-keystoneclient" -H "X-Auth-Token: cisco123" INFO:requests.packages.urllib3.connectionpool:Starting new HTTP connection (1): $http_proxy

Unable to establish connection to http://ubuntu-openstack:35357/v2.0/OS-KSADM/services (http://ubuntu-openstack:35357/v2.0/OS...)

wget establishes connection successfully. stack@ubuntu-openstack:~$ wget http://ubuntu-openstack:35357/v2.0/OS-KSADM/services (http://ubuntu-openstack:35357/v2.0/OS...)

--2014-07-03 07:51:01-- http://ubuntu-openstack:35357/v2.0/OS-KSADM/services (http://ubuntu-openstack:35357/v2.0/OS...) Resolving ubuntu-openstack (ubuntu-openstack)... 172.29.110.113 Connecting to ubuntu-openstack (ubuntu-openstack)|172.29.110.113|:35357... connected. HTTP request sent, awaiting response... 401 Unauthorized Authorization failed.

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2014-07-04 01:06:48 -0500

lekha gravatar image

Issue resolved. The HTTP proxy was not disabled properly causing issue.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-07-03 17:27:33 -0500

Seen: 1,204 times

Last updated: Jul 04 '14